# CVE-2024-32474: Sentry's superuser cleartext password leaked in logs

> Sentry leaks superuser passwords in cleartext logs, allowing attackers with log access to gain administrative control.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Apr 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-6cjm-4pxw-7xp9, PYSEC-2026-1911

## What is CVE-2024-32474?

CVE-2024-32474 is a high-severity vulnerability in getsentry sentry, published on 18 Apr 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Sentry is an error tracking and performance monitoring platform. Prior to 24.4.1, when authenticating as a superuser to Sentry with a username and password, the password is leaked as cleartext in logs under the _event_: `auth-index.validate_superuser`. An attacker with access to the log data could use these leaked credentials to login to the Sentry system as superuser. Self-hosted users on affected versions should upgrade to 24.4.1 or later. Users can configure the logging level to exclude logs of the `INFO` level and only generate logs for levels at `WARNING` or more.

Weakness: CWE-312 (Cleartext Storage of Sensitive Information), CWE-117 (Improper Output Neutralization for Logs)

## Which versions are affected by CVE-2024-32474?

3 open source packages ship an affected version, including sentry. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sentry` | PyPI | From 24.3.0 | 24.4.1 |
| `sentry` | PyPI | From 24.3.0 | 24.4.1 |
| `sentry` | PyPI | From 24.3.0 | 24.4.1 |

Products: Sentry Sentry.

## How do I fix CVE-2024-32474?

Upgrade sentry to 24.4.1 or later.

## Is CVE-2024-32474 being exploited?

There is no known exploitation of CVE-2024-32474 in the wild and no public exploit code.

## Other vulnerabilities in getsentry sentry

- [CVE-2026-42354](https://insights.sbomify.com/CVE-2026-42354/): Sentry: Improper authentication on SAML SSO process allows user identity linking (critical 9.1)
- [CVE-2026-27197](https://insights.sbomify.com/CVE-2026-27197/): Sentry: Improper Authentication on SAML SSO process allows user identity linking (critical 9.1)
- [CVE-2021-47935](https://insights.sbomify.com/CVE-2021-47935/): Sentry 8.2.0 Remote Code Execution via Pickle Deserialization (high 8.7)
- [CVE-2023-39349](https://insights.sbomify.com/CVE-2023-39349/): Sentry vulnerable to privilege escalation via ApiTokensEndpoint (high 8.1)
- [CVE-2023-36826](https://insights.sbomify.com/CVE-2023-36826/): Sentry vulnerable to improper authorization on debug and artifact file downloads (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-32474 and fix it if it is affected.

What it is: CVE-2024-32474 is a high-severity vulnerability in getsentry sentry, published on 18 Apr 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-32474 in the wild and no public exploit code.

Affected packages and fixed versions:
- sentry (PyPI): affected from 24.3.0; fixed in 24.4.1
- sentry (PyPI): affected from 24.3.0; fixed in 24.4.1
- sentry (PyPI): affected from 24.3.0; fixed in 24.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-32474/ (Markdown: https://insights.sbomify.com/CVE-2024-32474/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-32474
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-32474
- OSV: https://osv.dev/vulnerability/CVE-2024-32474

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-32474/
Summaries are generated and may contain mistakes; the official description above is the record.
