# CVE-2024-32478: Git Credential Manager (GCM)'s Debian package does not set root ownership on installed files

> A local attacker can replace Git Credential Manager binaries due to incorrect file ownership, gaining other users' privileges on multi-user systems.

- **Severity:** Medium 6.9 (`CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 19 Apr 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-3c3g-h9rx-f7vq

## What is CVE-2024-32478?

CVE-2024-32478 is a medium-severity vulnerability in git-ecosystem git-credential-manager, published on 19 Apr 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Git Credential Manager (GCM) is a secure Git credential helper. Prior to 2.5.0, the Debian package does not set root ownership on installed files. This allows user 1001 on a multi-user system can replace binary and gain other users' privileges. This vulnerability is fixed in 2.5.0.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2024-32478?


## How do I fix CVE-2024-32478?

No fix has been published for CVE-2024-32478 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-32478 being exploited?

There is no known exploitation of CVE-2024-32478 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-32478 and fix it if it is affected.

What it is: CVE-2024-32478 is a medium-severity vulnerability in git-ecosystem git-credential-manager, published on 19 Apr 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-32478 in the wild and no public exploit code.

Affected product: git-ecosystem git-credential-manager. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-32478/ (Markdown: https://insights.sbomify.com/CVE-2024-32478/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-32478
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-32478
- OSV: https://osv.dev/vulnerability/CVE-2024-32478

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-32478/
Summaries are generated and may contain mistakes; the official description above is the record.
