CVE-2024-32481 vyper's range(start, start + N) reverts for negative numbers

Medium 5.3 Published Updated

Attackers can cause smart contract execution to revert by supplying negative start values to range loops, leading to denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-32481?

CVE-2024-32481 is a medium-severity denial of service vulnerability in vyperlang vyper, published on 25 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Vyper is a pythonic Smart Contract Language for the Ethereum virtual machine. Starting in version 0.3.8 and prior to version 0.4.0b1, when looping over a `range` of the form `range(start, start + N)`, if `start` is negative, the execution will always revert. This issue is caused by an incorrect assertion inserted by the code generation of the range `stmt.parse_For_range()`. The issue arises when `start` is signed, instead of using `sle`, `le` is used and `start` is interpreted as an unsigned integer for the comparison. If it is a negative number, its 255th bit is set to `1` and is hence interpreted as a very large unsigned integer making the assertion always fail. Any contract having a `range(start, start + N)` where `start` is a signed integer with the possibility for `start` to be negative is affected. If a call goes through the loop while supplying a negative `start` the execution will revert. Version 0.4.0b1 fixes the issue.

Weakness: CWE-681

Which versions are affected by CVE-2024-32481?

3 open source packages ship an affected version, including vyper. It affects 1 product.

PackageAffectedFixed in
vyper PyPIFrom 0.3.80.4.0
vyper PyPIFrom 0.3.80.4.0
vyper PyPIFrom 0.3.80.4.0b1

Products include Vyperlang Vyper.

How do I fix CVE-2024-32481?

Upgrade vyper to a fixed version for your release line: 0.4.0 or 0.4.0b1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-32481 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-32481 exists.

Sources

Also known as GHSA-ppx5-q359-pvwj, PYSEC-2024-246.

Is CVE-2024-32481 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free