# CVE-2024-32481: vyper's range(start, start + N) reverts for negative numbers

> Attackers can cause smart contract execution to revert by supplying negative start values to range loops, leading to denial of service.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Apr 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-ppx5-q359-pvwj, PYSEC-2024-246

## What is CVE-2024-32481?

CVE-2024-32481 is a medium-severity denial of service vulnerability in vyperlang vyper, published on 25 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vyper is a pythonic Smart Contract Language for the Ethereum virtual machine. Starting in version 0.3.8 and prior to version 0.4.0b1, when looping over a `range` of the form `range(start, start + N)`, if `start` is negative, the execution will always revert. This issue is caused by an incorrect assertion inserted by the code generation of the range `stmt.parse_For_range()`. The issue arises when `start` is signed, instead of using `sle`, `le` is used and `start` is interpreted as an unsigned integer for the comparison. If it is a negative number, its 255th bit is set to `1` and is hence interpreted as a very large unsigned integer making the assertion always fail. Any contract having a `range(start, start + N)` where `start` is a signed integer with the possibility for `start` to be negative is affected. If a call goes through the loop while supplying a negative `start` the execution will revert. Version 0.4.0b1 fixes the issue.

Weakness: CWE-681 (Incorrect Conversion between Numeric Types)

## Which versions are affected by CVE-2024-32481?

3 open source packages ship an affected version, including vyper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vyper` | PyPI | From 0.3.8 | 0.4.0 |
| `vyper` | PyPI | From 0.3.8 | 0.4.0 |
| `vyper` | PyPI | From 0.3.8 | 0.4.0b1 |

Products: Vyperlang Vyper.

## How do I fix CVE-2024-32481?

Upgrade vyper to a fixed version for your release line: 0.4.0 or 0.4.0b1.

## Is CVE-2024-32481 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-32481 exists.

## Other vulnerabilities in vyperlang vyper

- [CVE-2024-24563](https://insights.sbomify.com/CVE-2024-24563/): Vyper array negative index vulnerability (critical 9.8)
- [CVE-2024-24561](https://insights.sbomify.com/CVE-2024-24561/): Vyper bounds check on built-in `slice()` function can be overflowed (critical 9.8)
- [CVE-2023-39363](https://insights.sbomify.com/CVE-2023-39363/): Vyper incorrectly allocated named re-entrancy locks (critical 9.1)
- [CVE-2022-24845](https://insights.sbomify.com/CVE-2022-24845/): Integer bounds error in Vyper (high 8.8)
- [CVE-2022-29255](https://insights.sbomify.com/CVE-2022-29255/): Multiple evaluation of contract address in call in vyper (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-32481 and fix it if it is affected.

What it is: CVE-2024-32481 is a medium-severity denial of service vulnerability in vyperlang vyper, published on 25 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-32481 exists.

Affected packages and fixed versions:
- vyper (PyPI): affected from 0.3.8; fixed in 0.4.0
- vyper (PyPI): affected from 0.3.8; fixed in 0.4.0
- vyper (PyPI): affected from 0.3.8; fixed in 0.4.0b1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-32481/ (Markdown: https://insights.sbomify.com/CVE-2024-32481/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-32481
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-32481
- OSV: https://osv.dev/vulnerability/CVE-2024-32481

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-32481/
Summaries are generated and may contain mistakes; the official description above is the record.
