# CVE-2024-3250: Pebble service manager's file pull API allows access by any user

> Unprivileged local users can read arbitrary files with root permissions via the Pebble read-file API when running as root.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Apr 2024
- **Updated:** 6 Nov 2024
- **Also known as:** BIT-pebble-2024-3250, GHSA-4685-2x5r-65pj, GO-2024-2692

## What is CVE-2024-3250?

CVE-2024-3250 is a medium-severity missing authorization vulnerability in Canonical Ltd. Pebble, published on 4 Apr 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

It was discovered that Canonical's Pebble service manager read-file API and the associated pebble pull command, before v1.10.2, allowed unprivileged local users to read files with root-equivalent permissions when Pebble was running as root. Fixes are also available as backports to v1.1.1, v1.4.2, and v1.7.4.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2024-3250?

10 open source packages ship an affected version, including github.com/canonical/pebble and pebble. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/canonical/pebble` | Go | All versions | 1.1.1, 1.4.2, 1.7.3, 1.10.2 |
| `github.com/canonical/pebble` | Go | All versions | 1.1.1 |
| `github.com/canonical/pebble` | Go | All versions | 1.1.1 |
| `github.com/canonical/pebble` | Go | From 1.2.0 | 1.4.2 |
| `github.com/canonical/pebble` | Go | From 1.2.0 | 1.4.2 |
| `github.com/canonical/pebble` | Go | From 1.5.0 | 1.7.3 |
| `github.com/canonical/pebble` | Go | From 1.5.0 | 1.7.3 |
| `github.com/canonical/pebble` | Go | From 1.8.0 | 1.10.2 |
| `github.com/canonical/pebble` | Go | From 1.8.0 | 1.10.2 |
| `pebble` | Bitnami | All versions | 1.4.1, 1.7.3, 1.10.2 |

Products: Canonical Pebble.

## How do I fix CVE-2024-3250?

Upgrade github.com/canonical/pebble to a fixed version for your release line: 1.1.1, 1.4.2, 1.7.3 or 1.10.2.

## Is CVE-2024-3250 being exploited?

There is no known exploitation of CVE-2024-3250 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-3250 and fix it if it is affected.

What it is: CVE-2024-3250 is a medium-severity missing authorization vulnerability in Canonical Ltd. Pebble, published on 4 Apr 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-3250 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/canonical/pebble (Go): affected all versions; fixed in 1.1.1, 1.4.2, 1.7.3, 1.10.2
- github.com/canonical/pebble (Go): affected all versions; fixed in 1.1.1
- github.com/canonical/pebble (Go): affected all versions; fixed in 1.1.1
- github.com/canonical/pebble (Go): affected from 1.2.0; fixed in 1.4.2
- github.com/canonical/pebble (Go): affected from 1.2.0; fixed in 1.4.2
- github.com/canonical/pebble (Go): affected from 1.5.0; fixed in 1.7.3
- github.com/canonical/pebble (Go): affected from 1.5.0; fixed in 1.7.3
- github.com/canonical/pebble (Go): affected from 1.8.0; fixed in 1.10.2
- github.com/canonical/pebble (Go): affected from 1.8.0; fixed in 1.10.2
- pebble (Bitnami): affected all versions; fixed in 1.4.1, 1.7.3, 1.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-3250/ (Markdown: https://insights.sbomify.com/CVE-2024-3250/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-3250
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-3250
- OSV: https://osv.dev/vulnerability/CVE-2024-3250

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-3250/
Summaries are generated and may contain mistakes; the official description above is the record.
