CVE-2024-32638 Apache APISIX: Forward-Auth Request Smuggling
Attackers can exploit HTTP request smuggling in the forward-auth plugin to bypass security controls or access unauthorized data.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-32638?
CVE-2024-32638 is a medium-severity vulnerability in Apache APISIX, published on 2 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') vulnerability in Apache APISIX when using `forward-auth` plugin.This issue affects Apache APISIX: from 3.8.0, 3.9.0.
Users are recommended to upgrade to version 3.8.1, 3.9.1 or higher, which fixes the issue.
Weakness: CWE-444
Which versions are affected by CVE-2024-32638?
1 open source package ship an affected version, including apisix. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apisix Bitnami | From 3.8.0 | 3.9.1 |
Products include Apache Apisix.
How do I fix CVE-2024-32638?
Upgrade apisix to 3.9.1 or later.
Is CVE-2024-32638 being exploited?
There is no known exploitation of CVE-2024-32638 in the wild and no public exploit code.
Other vulnerabilities in Apache APISIX
- CVE-2022-24112 Apache APISIX Authentication Bypass
- CVE-2022-25757 Apache APISIX: the body_schema check in request-validation plugin can be bypassed
- CVE-2026-31908 Apache APISIX: forward auth plugin allows header injection
- CVE-2026-75005 Apache APISIX: Unauthenticated CPU-exhaustion DoS
- CVE-2025-27446 Privilege escalation in Apache APISIX Java Plugin Runner
Sources
Also known as BIT-apisix-2024-32638, GHSA-8g74-32fg-5ghc.