# CVE-2024-32638: Apache APISIX: Forward-Auth Request Smuggling

> Attackers can exploit HTTP request smuggling in the forward-auth plugin to bypass security controls or access unauthorized data.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 May 2024
- **Updated:** 13 Feb 2025
- **Also known as:** BIT-apisix-2024-32638, GHSA-8g74-32fg-5ghc

## What is CVE-2024-32638?

CVE-2024-32638 is a medium-severity vulnerability in Apache APISIX, published on 2 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') vulnerability in Apache APISIX when using `forward-auth` plugin.This issue affects Apache APISIX: from 3.8.0, 3.9.0.

Users are recommended to upgrade to version 3.8.1, 3.9.1 or higher, which fixes the issue.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2024-32638?

1 open source package ship an affected version, including apisix. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apisix` | Bitnami | From 3.8.0 | 3.9.1 |

Products: Apache Apisix.

## How do I fix CVE-2024-32638?

Upgrade apisix to 3.9.1 or later.

## Is CVE-2024-32638 being exploited?

There is no known exploitation of CVE-2024-32638 in the wild and no public exploit code.

## Other vulnerabilities in Apache APISIX

- [CVE-2022-24112](https://insights.sbomify.com/CVE-2022-24112/): Apache APISIX Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2022-25757](https://insights.sbomify.com/CVE-2022-25757/): Apache APISIX: the body_schema check in request-validation plugin can be bypassed (critical 9.8)
- [CVE-2026-31908](https://insights.sbomify.com/CVE-2026-31908/): Apache APISIX: forward auth plugin allows header injection (critical 9.1)
- [CVE-2026-75005](https://insights.sbomify.com/CVE-2026-75005/): Apache APISIX: Unauthenticated CPU-exhaustion DoS (high 8.7)
- [CVE-2025-27446](https://insights.sbomify.com/CVE-2025-27446/): Privilege escalation in Apache APISIX Java Plugin Runner (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-32638 and fix it if it is affected.

What it is: CVE-2024-32638 is a medium-severity vulnerability in Apache APISIX, published on 2 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-32638 in the wild and no public exploit code.

Affected packages and fixed versions:
- apisix (Bitnami): affected from 3.8.0; fixed in 3.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-32638/ (Markdown: https://insights.sbomify.com/CVE-2024-32638/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-32638
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-32638
- OSV: https://osv.dev/vulnerability/CVE-2024-32638

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-32638/
Summaries are generated and may contain mistakes; the official description above is the record.
