# CVE-2024-32648: vyper default functions don't respect nonreentrancy keys

> Vyper compiler fails to enforce non-reentrancy locks on default functions, potentially allowing reentrancy attacks in smart contracts.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Apr 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-m2v9-w374-5hj9, PYSEC-2024-163

## What is CVE-2024-32648?

CVE-2024-32648 is a medium-severity vulnerability in vyperlang vyper, published on 25 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vyper is a pythonic Smart Contract Language for the Ethereum virtual machine. Prior to version 0.3.0, default functions don't respect nonreentrancy keys and the lock isn't emitted. No vulnerable production contracts were found. Additionally, using a lock on a `default` function is a very sparsely used pattern. As such, the impact is low. Version 0.3.0 contains a patch for the issue.

Weakness: CWE-667 (Improper Locking)

## Which versions are affected by CVE-2024-32648?

3 open source packages ship an affected version, including vyper. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vyper` | PyPI | All versions | 0.3.0 |
| `vyper` | PyPI | All versions | 0.3.0 |
| `vyper` | PyPI | All versions | 0.3.0 |

Products: Vyperlang Vyper.

## How do I fix CVE-2024-32648?

Upgrade vyper to 0.3.0 or later.

## Is CVE-2024-32648 being exploited?

There is no known exploitation of CVE-2024-32648 in the wild and no public exploit code.

## Other vulnerabilities in vyperlang vyper

- [CVE-2024-24563](https://insights.sbomify.com/CVE-2024-24563/): Vyper array negative index vulnerability (critical 9.8)
- [CVE-2024-24561](https://insights.sbomify.com/CVE-2024-24561/): Vyper bounds check on built-in `slice()` function can be overflowed (critical 9.8)
- [CVE-2023-39363](https://insights.sbomify.com/CVE-2023-39363/): Vyper incorrectly allocated named re-entrancy locks (critical 9.1)
- [CVE-2022-24845](https://insights.sbomify.com/CVE-2022-24845/): Integer bounds error in Vyper (high 8.8)
- [CVE-2022-29255](https://insights.sbomify.com/CVE-2022-29255/): Multiple evaluation of contract address in call in vyper (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-32648 and fix it if it is affected.

What it is: CVE-2024-32648 is a medium-severity vulnerability in vyperlang vyper, published on 25 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-32648 in the wild and no public exploit code.

Affected packages and fixed versions:
- vyper (PyPI): affected all versions; fixed in 0.3.0
- vyper (PyPI): affected all versions; fixed in 0.3.0
- vyper (PyPI): affected all versions; fixed in 0.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-32648/ (Markdown: https://insights.sbomify.com/CVE-2024-32648/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-32648
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-32648
- OSV: https://osv.dev/vulnerability/CVE-2024-32648

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-32648/
Summaries are generated and may contain mistakes; the official description above is the record.
