# CVE-2024-32652: @hono/node-server contains Denial of Service risk when receiving Host header that cannot be parsed

> An attacker can cause a denial of service by sending a malformed Host header to applications using the @hono/node-server adapter.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Apr 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-hgxw-5xg3-69jx

## What is CVE-2024-32652?

CVE-2024-32652 is a high-severity denial of service vulnerability in honojs node-server, published on 19 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The adapter @hono/node-server allows you to run your Hono application on Node.js. Prior to 1.10.1, the application hangs when receiving a Host header with a value that `@hono/node-server` can't handle well. Invalid values are those that cannot be parsed by the `URL` as a hostname such as an empty string, slashes `/`, and other strings. The version 1.10.1 includes the fix for this issue.

Weakness: CWE-755 (Improper Handling of Exceptional Conditions)

## Which versions are affected by CVE-2024-32652?

2 open source packages ship an affected version, including @hono/node-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@hono/node-server` | npm | From 1.3.0 | 1.10.1 |
| `@hono/node-server` | npm | From 1.3.0 | 1.10.1 |

Products: Hono Node-Server.

## How do I fix CVE-2024-32652?

Upgrade @hono/node-server to 1.10.1 or later.

## Is CVE-2024-32652 being exploited?

There is no known exploitation of CVE-2024-32652 in the wild and no public exploit code.

## Other vulnerabilities in honojs node-server

- [CVE-2026-29087](https://insights.sbomify.com/CVE-2026-29087/): @hono/node-server: Authorization bypass for protected static paths via encoded slashes in Serve Static Middleware (high 7.5)
- [CVE-2026-39406](https://insights.sbomify.com/CVE-2026-39406/): @hono/node-server has a middleware bypass via repeated slashes in serveStatic (medium 5.3)
- [CVE-2024-23340](https://insights.sbomify.com/CVE-2024-23340/): @hono/node-server can't handle "double dots" in URL (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-32652 and fix it if it is affected.

What it is: CVE-2024-32652 is a high-severity denial of service vulnerability in honojs node-server, published on 19 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-32652 in the wild and no public exploit code.

Affected packages and fixed versions:
- @hono/node-server (npm): affected from 1.3.0; fixed in 1.10.1
- @hono/node-server (npm): affected from 1.3.0; fixed in 1.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-32652/ (Markdown: https://insights.sbomify.com/CVE-2024-32652/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-32652
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-32652
- OSV: https://osv.dev/vulnerability/CVE-2024-32652

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-32652/
Summaries are generated and may contain mistakes; the official description above is the record.
