{"answers":{"affected":"2 open source packages ship an affected version, including io.antmedia:ant-media-server.","exploited":"There is no known exploitation of CVE-2024-32656 in the wild and no public exploit code.","fix":"Upgrade io.antmedia:ant-media-server to 2.9.0 or later.","what":"CVE-2024-32656 is a high-severity vulnerability in Ant-Media-Server, published on 22 Apr 2024. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-32656 and fix it if it is affected.\n\nWhat it is: CVE-2024-32656 is a high-severity vulnerability in Ant-Media-Server, published on 22 Apr 2024. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-32656 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.antmedia:ant-media-server (Maven): affected from 2.6.0; fixed in 2.9.0\n- io.antmedia:ant-media-server (Maven): affected from 2.6.0; fixed in 2.9.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-32656/ (Markdown: https://insights.sbomify.com/CVE-2024-32656/index.md)","id":"CVE-2024-32656","markdown":"https://insights.sbomify.com/CVE-2024-32656/index.md","name":"CVE-2024-32656","record":{"aliases":["GHSA-qwhw-hh9j-54f5"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Ant Media Server","requires_auth":"low_privilege","summary":"Local attackers can escalate privileges to root by exploiting an unauthenticated JMX service on localhost to execute arbitrary code.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"Ant Media Server is live streaming engine software. A local privilege escalation vulnerability in present in versions 2.6.0 through 2.8.2 allows any unprivileged operating system user account to escalate privileges to the root user account on the system. This vulnerability arises from Ant Media Server running with Java Management Extensions (JMX) enabled and authentication disabled on localhost on port 5599/TCP. This vulnerability is nearly identical to the local privilege escalation vulnerability CVE-2023-26269 identified in Apache James. Any unprivileged operating system user can connect to the JMX service running on port 5599/TCP on localhost and leverage the MLet Bean within JMX to load a remote MBean from an attacker-controlled server. This allows an attacker to execute arbitrary code within the Java process run by Ant Media Server and execute code within the context of the `antmedia` service account on the system. Version 2.9.0 contains a patch for the issue. As a workaround, one may remove certain parameters from the `antmedia.service` file.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Ant Media Server vulnerable to local privilege escalation","id":"CVE-2024-32656","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"privilege_escalation","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Hydra has persistent XSS vulnerability serving HTML build outputs","id":"CVE-2024-32657"},"packages":[{"ecosystem":"Maven","fixed":["2.9.0"],"introduced":["2.6.0"],"last_affected":[],"package":"io.antmedia:ant-media-server","purl":null,"source":"GHSA-qwhw-hh9j-54f5"},{"ecosystem":"Maven","fixed":["2.9.0"],"introduced":["2.6.0"],"last_affected":[],"package":"io.antmedia:ant-media-server","purl":"pkg:maven/io.antmedia/ant-media-server","source":"GHSA-qwhw-hh9j-54f5"}],"prev":{"headline":"Npgsql Vulnerable to SQL Injection via Protocol Message Size Overflow","id":"CVE-2024-32655"},"products":["Ant-Media-Server"],"published":"2024-04-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["ant-media"]},"summary":"Local attackers can escalate privileges to root by exploiting an unauthenticated JMX service on localhost to execute arbitrary code.","url":"https://insights.sbomify.com/CVE-2024-32656/"}