# CVE-2024-32656: Ant Media Server vulnerable to local privilege escalation

> Local attackers can escalate privileges to root by exploiting an unauthenticated JMX service on localhost to execute arbitrary code.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Apr 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-qwhw-hh9j-54f5

## What is CVE-2024-32656?

CVE-2024-32656 is a high-severity vulnerability in Ant-Media-Server, published on 22 Apr 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Ant Media Server is live streaming engine software. A local privilege escalation vulnerability in present in versions 2.6.0 through 2.8.2 allows any unprivileged operating system user account to escalate privileges to the root user account on the system. This vulnerability arises from Ant Media Server running with Java Management Extensions (JMX) enabled and authentication disabled on localhost on port 5599/TCP. This vulnerability is nearly identical to the local privilege escalation vulnerability CVE-2023-26269 identified in Apache James. Any unprivileged operating system user can connect to the JMX service running on port 5599/TCP on localhost and leverage the MLet Bean within JMX to load a remote MBean from an attacker-controlled server. This allows an attacker to execute arbitrary code within the Java process run by Ant Media Server and execute code within the context of the `antmedia` service account on the system. Version 2.9.0 contains a patch for the issue. As a workaround, one may remove certain parameters from the `antmedia.service` file.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2024-32656?

2 open source packages ship an affected version, including io.antmedia:ant-media-server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.antmedia:ant-media-server` | Maven | From 2.6.0 | 2.9.0 |
| `io.antmedia:ant-media-server` | Maven | From 2.6.0 | 2.9.0 |

## How do I fix CVE-2024-32656?

Upgrade io.antmedia:ant-media-server to 2.9.0 or later.

## Is CVE-2024-32656 being exploited?

There is no known exploitation of CVE-2024-32656 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-32656 and fix it if it is affected.

What it is: CVE-2024-32656 is a high-severity vulnerability in Ant-Media-Server, published on 22 Apr 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-32656 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.antmedia:ant-media-server (Maven): affected from 2.6.0; fixed in 2.9.0
- io.antmedia:ant-media-server (Maven): affected from 2.6.0; fixed in 2.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-32656/ (Markdown: https://insights.sbomify.com/CVE-2024-32656/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-32656
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-32656
- OSV: https://osv.dev/vulnerability/CVE-2024-32656

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-32656/
Summaries are generated and may contain mistakes; the official description above is the record.
