# CVE-2024-3271: Command Injection in run-llama/llama_index

> Attackers can bypass security checks in the safe_eval function to execute arbitrary OS commands, leading to remote code execution on the host.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Apr 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-r6gp-rff2-p3hf, PYSEC-2026-396

## What is CVE-2024-3271?

CVE-2024-3271 is a critical command injection vulnerability in run-llama/llama_index, published on 16 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A command injection vulnerability exists in the run-llama/llama_index repository, specifically within the safe_eval function. Attackers can bypass the intended security mechanism, which checks for the presence of underscores in code generated by LLM, to execute arbitrary code. This is achieved by crafting input that does not contain an underscore but still results in the execution of OS commands. The vulnerability allows for remote code execution (RCE) on the server hosting the application.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2024-3271?

3 open source packages ship an affected version, including llama-index-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `llama-index-core` | PyPI | All versions | 0.10.24 |
| `llama-index-core` | PyPI | All versions | 0.10.24 |
| `llama-index-core` | PyPI | All versions | 0.10.24 |

Products: Llamaindex Llamaindex.

## How do I fix CVE-2024-3271?

Upgrade llama-index-core to 0.10.24 or later.

## Is CVE-2024-3271 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3271 exists.

## Other vulnerabilities in run-llama/llama_index

- [CVE-2024-12909](https://insights.sbomify.com/CVE-2024-12909/): SQL Injection to RCE in run-llama/llama_index (critical 10.0)
- [CVE-2025-1793](https://insights.sbomify.com/CVE-2025-1793/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2025-1750](https://insights.sbomify.com/CVE-2025-1750/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2024-11958](https://insights.sbomify.com/CVE-2024-11958/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2024-23751](https://insights.sbomify.com/CVE-2024-23751/): SQL injection in llama-index (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-3271 and fix it if it is affected.

What it is: CVE-2024-3271 is a critical command injection vulnerability in run-llama/llama_index, published on 16 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3271 exists.

Affected packages and fixed versions:
- llama-index-core (PyPI): affected all versions; fixed in 0.10.24
- llama-index-core (PyPI): affected all versions; fixed in 0.10.24
- llama-index-core (PyPI): affected all versions; fixed in 0.10.24

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-3271/ (Markdown: https://insights.sbomify.com/CVE-2024-3271/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-3271
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-3271
- OSV: https://osv.dev/vulnerability/CVE-2024-3271

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-3271/
Summaries are generated and may contain mistakes; the official description above is the record.
