# CVE-2024-32866: Conform contains Prototype Pollution Vulnerability in `parseWith...` function

> Prototype pollution in Conform allows attackers to manipulate object prototypes via crafted inputs, potentially leading to code execution or privilege escalation.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Apr 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-624g-8qjg-8qxf

## What is CVE-2024-32866?

CVE-2024-32866 is a high-severity vulnerability in edmundhung conform, published on 23 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Conform, a type-safe form validation library, allows the parsing of nested objects in the form of `object.property`. Due to an improper implementation of this feature in versions prior to 1.1.1, an attacker can exploit the feature to trigger prototype pollution by passing a crafted input to `parseWith...` functions. Applications that use conform for server-side validation of form data or URL parameters are affected by this vulnerability. Version 1.1.1 contains a patch for the issue.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2024-32866?

12 open source packages ship an affected version, including @conform-to/dom, @conform-to/yup and @conform-to/zod.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@conform-to/dom` | npm | All versions | 0.9.2 |
| `@conform-to/dom` | npm | All versions | 0.9.2 |
| `@conform-to/dom` | npm | From 1.0.0 | 1.1.1 |
| `@conform-to/dom` | npm | From 1.0.0 | 1.1.1 |
| `@conform-to/yup` | npm | All versions | 0.9.2 |
| `@conform-to/yup` | npm | All versions | 0.9.2 |
| `@conform-to/yup` | npm | From 1.0.0 | 1.1.1 |
| `@conform-to/yup` | npm | From 1.0.0 | 1.1.1 |
| `@conform-to/zod` | npm | All versions | 0.9.2 |
| `@conform-to/zod` | npm | All versions | 0.9.2 |
| `@conform-to/zod` | npm | From 1.0.0 | 1.1.1 |
| `@conform-to/zod` | npm | From 1.0.0 | 1.1.1 |

## How do I fix CVE-2024-32866?

Upgrade @conform-to/dom to a fixed version for your release line: 0.9.2 or 1.1.1.

## Is CVE-2024-32866 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-32866 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-32866 and fix it if it is affected.

What it is: CVE-2024-32866 is a high-severity vulnerability in edmundhung conform, published on 23 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-32866 exists.

Affected packages and fixed versions:
- @conform-to/dom (npm): affected all versions; fixed in 0.9.2
- @conform-to/dom (npm): affected all versions; fixed in 0.9.2
- @conform-to/dom (npm): affected from 1.0.0; fixed in 1.1.1
- @conform-to/dom (npm): affected from 1.0.0; fixed in 1.1.1
- @conform-to/yup (npm): affected all versions; fixed in 0.9.2
- @conform-to/yup (npm): affected all versions; fixed in 0.9.2
- @conform-to/yup (npm): affected from 1.0.0; fixed in 1.1.1
- @conform-to/yup (npm): affected from 1.0.0; fixed in 1.1.1
- @conform-to/zod (npm): affected all versions; fixed in 0.9.2
- @conform-to/zod (npm): affected all versions; fixed in 0.9.2
- @conform-to/zod (npm): affected from 1.0.0; fixed in 1.1.1
- @conform-to/zod (npm): affected from 1.0.0; fixed in 1.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-32866/ (Markdown: https://insights.sbomify.com/CVE-2024-32866/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-32866
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-32866
- OSV: https://osv.dev/vulnerability/CVE-2024-32866

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-32866/
Summaries are generated and may contain mistakes; the official description above is the record.
