CVE-2024-32871 Pimcore Vulnerable to Flooding Server with Thumbnail files

High 7.5 Published Updated

Attackers can flood the server with large thumbnail files by manipulating scaling factors, causing resource exhaustion and denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-32871?

CVE-2024-32871 is a high-severity denial of service vulnerability in Pimcore Pimcore, published on 4 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Pimcore is an Open Source Data & Experience Management Platform. The Pimcore thumbnail generation can be used to flood the server with large files. By changing the file extension or scaling factor of the requested thumbnail, attackers can create files that are much larger in file size than the original. This vulnerability is fixed in 11.2.4.

Weakness: CWE-770

Which versions are affected by CVE-2024-32871?

2 open source packages ship an affected version, including pimcore/pimcore. It affects 1 product.

PackageAffectedFixed in
pimcore/pimcore PackagistFrom 11.0.011.2.4
pimcore/pimcore PackagistFrom 11.0.011.2.4

Products include Pimcore Pimcore.

How do I fix CVE-2024-32871?

Upgrade pimcore/pimcore to 11.2.4 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-32871 being exploited?

There is no known exploitation of CVE-2024-32871 in the wild and no public exploit code.

All Pimcore Pimcore vulnerabilities

Sources

Also known as GHSA-277c-5vvj-9pwx.

Is CVE-2024-32871 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free