# CVE-2024-32871: Pimcore Vulnerable to Flooding Server with Thumbnail files

> Attackers can flood the server with large thumbnail files by manipulating scaling factors, causing resource exhaustion and denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jun 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-277c-5vvj-9pwx

## What is CVE-2024-32871?

CVE-2024-32871 is a high-severity denial of service vulnerability in Pimcore Pimcore, published on 4 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Pimcore is an Open Source Data & Experience Management Platform. The Pimcore thumbnail generation can be used to flood the server with large files. By changing the file extension or scaling factor of the requested thumbnail, attackers can create files that are much larger in file size than the original. This vulnerability is fixed in 11.2.4.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2024-32871?

2 open source packages ship an affected version, including pimcore/pimcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pimcore/pimcore` | Packagist | From 11.0.0 | 11.2.4 |
| `pimcore/pimcore` | Packagist | From 11.0.0 | 11.2.4 |

Products: Pimcore Pimcore.

## How do I fix CVE-2024-32871?

Upgrade pimcore/pimcore to 11.2.4 or later.

## Is CVE-2024-32871 being exploited?

There is no known exploitation of CVE-2024-32871 in the wild and no public exploit code.

## Other vulnerabilities in Pimcore Pimcore

- [CVE-2022-39365](https://insights.sbomify.com/CVE-2022-39365/): RCE vulnerability in Pimcore/Mail & Dynamic Text Layout (critical 9.8)
- [CVE-2019-18981](https://insights.sbomify.com/CVE-2019-18981/): Pimcore Access Control Issues (critical 9.8)
- [CVE-2019-18985](https://insights.sbomify.com/CVE-2019-18985/): Pimcore 2FA Vulnerable to Brute Forcing (critical 9.8)
- [CVE-2026-23492](https://insights.sbomify.com/CVE-2026-23492/): Pimcore has a Blind SQL Injection in Admin Search Find API due to an incomplete fix for CVE-2023-30848 (high 8.8)
- [CVE-2023-47637](https://insights.sbomify.com/CVE-2023-47637/): SQL Injection in Admin Grid Filter API in Pimcore (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-32871 and fix it if it is affected.

What it is: CVE-2024-32871 is a high-severity denial of service vulnerability in Pimcore Pimcore, published on 4 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-32871 in the wild and no public exploit code.

Affected packages and fixed versions:
- pimcore/pimcore (Packagist): affected from 11.0.0; fixed in 11.2.4
- pimcore/pimcore (Packagist): affected from 11.0.0; fixed in 11.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-32871/ (Markdown: https://insights.sbomify.com/CVE-2024-32871/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-32871
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-32871
- OSV: https://osv.dev/vulnerability/CVE-2024-32871

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-32871/
Summaries are generated and may contain mistakes; the official description above is the record.
