# CVE-2024-32874: In Frigate, Malicious Long Unicode filenames may cause a Multiple Application-level Denial of Service

> Attackers can cause application-level denial of service in Frigate by uploading files with excessively long Unicode filenames.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-w4h6-9wrp-v5jq, PYSEC-2026-342

## What is CVE-2024-32874?

CVE-2024-32874 is a medium-severity denial of service vulnerability in blakeblackshear frigate, published on 9 May 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Frigate is a network video recorder (NVR) with realtime local object detection for IP cameras. Below 0.13.2 Release, when uploading a file or retrieving the filename, a user may intentionally use a large Unicode filename which would lead to a application-level denial of service. This is due to no limitation set on the length of the filename and the costy use of the Unicode normalization with the form NFKD under the hood of `secure_filename()`.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2024-32874?

3 open source packages ship an affected version, including frigate.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `frigate` | PyPI | All versions | 0.13.2 |
| `frigate` | PyPI | All versions | 0.13.2 |
| `frigate` | PyPI | All versions | 0.13.2 |

## How do I fix CVE-2024-32874?

Upgrade frigate to 0.13.2 or later.

## Is CVE-2024-32874 being exploited?

There is no known exploitation of CVE-2024-32874 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-32874 and fix it if it is affected.

What it is: CVE-2024-32874 is a medium-severity denial of service vulnerability in blakeblackshear frigate, published on 9 May 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-32874 in the wild and no public exploit code.

Affected packages and fixed versions:
- frigate (PyPI): affected all versions; fixed in 0.13.2
- frigate (PyPI): affected all versions; fixed in 0.13.2
- frigate (PyPI): affected all versions; fixed in 0.13.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-32874/ (Markdown: https://insights.sbomify.com/CVE-2024-32874/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-32874
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-32874
- OSV: https://osv.dev/vulnerability/CVE-2024-32874

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-32874/
Summaries are generated and may contain mistakes; the official description above is the record.
