{"answers":{"affected":"2 open source packages ship an affected version, including yiisoft/yii2. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-32877 in the wild and no public exploit code.","fix":"Upgrade yiisoft/yii2 to 2.0.49.4 or later.","what":"CVE-2024-32877 is a medium-severity cross-site scripting vulnerability in yiisoft yii2, published on 30 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-32877 and fix it if it is affected.\n\nWhat it is: CVE-2024-32877 is a medium-severity cross-site scripting vulnerability in yiisoft yii2, published on 30 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-32877 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- yiisoft/yii2 (Packagist): affected from 2.0.43; fixed in 2.0.49.4\n- yiisoft/yii2 (Packagist): affected from 2.0.43; fixed in 2.0.49.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-32877/ (Markdown: https://insights.sbomify.com/CVE-2024-32877/index.md)","id":"CVE-2024-32877","markdown":"https://insights.sbomify.com/CVE-2024-32877/index.md","name":"CVE-2024-32877","record":{"aliases":["GHSA-qg5r-95m4-mjgj"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"PHP application framework","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript via reflected XSS in Yii2 debug mode, potentially stealing cookies or taking over accounts.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"yii","vendor":"yiiframework"}],"cvss":{"score":4.2,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Yii 2 is a PHP application framework. During internal penetration testing of a product based on Yii2, users discovered a Cross-site Scripting (XSS) vulnerability within the framework itself. This issue is relevant for the latest version of Yii2 (2.0.49.3). This issue lies in the mechanism for displaying function argument values in the stack trace. The vulnerability manifests when an argument's value exceeds 32 characters. For convenience, argument values exceeding this limit are truncated and displayed with an added \"...\". The full argument value becomes visible when hovering over it with the mouse, as it is displayed in the title attribute of a span tag. However, the use of a double quote (\") allows an attacker to break out of the title attribute's value context and inject their own attributes into the span tag, including malicious JavaScript code through event handlers such as onmousemove. This vulnerability allows an attacker to execute arbitrary JavaScript code in the security context of the victim's site via a specially crafted link. This could lead to the theft of cookies (including httpOnly cookies, which are accessible on the page), content substitution, or complete takeover of user accounts. This issue has been addressed in version 2.0.50. Users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Reflected Cross-site Scripting in yiisoft/yii2 Debug mode","id":"CVE-2024-32877","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Use of Uninitialized Variable Vulnerability in llama.cpp","id":"CVE-2024-32878"},"packages":[{"ecosystem":"Packagist","fixed":["2.0.49.4"],"introduced":["2.0.43"],"last_affected":[],"package":"yiisoft/yii2","purl":null,"source":"GHSA-qg5r-95m4-mjgj"},{"ecosystem":"Packagist","fixed":["2.0.49.4"],"introduced":["2.0.43"],"last_affected":[],"package":"yiisoft/yii2","purl":"pkg:composer/yiisoft/yii2","source":"GHSA-qg5r-95m4-mjgj"}],"prev":{"headline":"NewPipe has potential security vulnerability when importing settings","id":"CVE-2024-32876"},"products":["yii2"],"published":"2024-05-30","related":[{"cvss_score":9,"headline":"Yiiframework Yii Improper Protection of Alternate Path","id":"CVE-2024-58136","kev_date_added":"2025-05-02","published":"2025-04-10"},{"cvss_score":9.8,"headline":"Yii2 allows attackers to execute any local .php file via a relative path in the view parameter","id":"CVE-2015-5467","kev_date_added":null,"published":"2023-09-21"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2023-26750","kev_date_added":null,"published":"2023-04-04"},{"cvss_score":9.8,"headline":"Yii SQL injection vulnerability","id":"CVE-2018-7269","kev_date_added":null,"published":"2018-03-21"},{"cvss_score":9.8,"headline":"yii2-redis Potential Remote code execution","id":"CVE-2018-8073","kev_date_added":null,"published":"2018-03-21"},{"cvss_score":8.9,"headline":"Unsafe deserialization in Yii 2","id":"CVE-2020-15148","kev_date_added":null,"published":"2020-09-15"},{"cvss_score":8.1,"headline":"Unsafe Reflection in base Component class in yiisoft/yii2","id":"CVE-2024-4990","kev_date_added":null,"published":"2025-03-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["yiisoft"]},"summary":"Attackers can execute arbitrary JavaScript via reflected XSS in Yii2 debug mode, potentially stealing cookies or taking over accounts.","url":"https://insights.sbomify.com/CVE-2024-32877/"}