# CVE-2024-32877: Reflected Cross-site Scripting in yiisoft/yii2 Debug mode

> Attackers can execute arbitrary JavaScript via reflected XSS in Yii2 debug mode, potentially stealing cookies or taking over accounts.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-qg5r-95m4-mjgj

## What is CVE-2024-32877?

CVE-2024-32877 is a medium-severity cross-site scripting vulnerability in yiisoft yii2, published on 30 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Yii 2 is a PHP application framework. During internal penetration testing of a product based on Yii2, users discovered a Cross-site Scripting (XSS) vulnerability within the framework itself. This issue is relevant for the latest version of Yii2 (2.0.49.3). This issue lies in the mechanism for displaying function argument values in the stack trace. The vulnerability manifests when an argument's value exceeds 32 characters. For convenience, argument values exceeding this limit are truncated and displayed with an added "...". The full argument value becomes visible when hovering over it with the mouse, as it is displayed in the title attribute of a span tag. However, the use of a double quote (") allows an attacker to break out of the title attribute's value context and inject their own attributes into the span tag, including malicious JavaScript code through event handlers such as onmousemove. This vulnerability allows an attacker to execute arbitrary JavaScript code in the security context of the victim's site via a specially crafted link. This could lead to the theft of cookies (including httpOnly cookies, which are accessible on the page), content substitution, or complete takeover of user accounts. This issue has been addressed in version 2.0.50. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-32877?

2 open source packages ship an affected version, including yiisoft/yii2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yiisoft/yii2` | Packagist | From 2.0.43 | 2.0.49.4 |
| `yiisoft/yii2` | Packagist | From 2.0.43 | 2.0.49.4 |

Products: Yiiframework Yii.

## How do I fix CVE-2024-32877?

Upgrade yiisoft/yii2 to 2.0.49.4 or later.

## Is CVE-2024-32877 being exploited?

There is no known exploitation of CVE-2024-32877 in the wild and no public exploit code.

## Other vulnerabilities in yiisoft yii2

- [CVE-2024-58136](https://insights.sbomify.com/CVE-2024-58136/): Yiiframework Yii Improper Protection of Alternate Path (critical 9.0, exploited in the wild)
- [CVE-2015-5467](https://insights.sbomify.com/CVE-2015-5467/): Yii2 allows attackers to execute any local .php file via a relative path in the view parameter (critical 9.8)
- [CVE-2023-26750](https://insights.sbomify.com/CVE-2023-26750/): SQL injection in n/a (critical 9.8)
- [CVE-2018-7269](https://insights.sbomify.com/CVE-2018-7269/): Yii SQL injection vulnerability (critical 9.8)
- [CVE-2018-8073](https://insights.sbomify.com/CVE-2018-8073/): yii2-redis Potential Remote code execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-32877 and fix it if it is affected.

What it is: CVE-2024-32877 is a medium-severity cross-site scripting vulnerability in yiisoft yii2, published on 30 May 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-32877 in the wild and no public exploit code.

Affected packages and fixed versions:
- yiisoft/yii2 (Packagist): affected from 2.0.43; fixed in 2.0.49.4
- yiisoft/yii2 (Packagist): affected from 2.0.43; fixed in 2.0.49.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-32877/ (Markdown: https://insights.sbomify.com/CVE-2024-32877/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-32877
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-32877
- OSV: https://osv.dev/vulnerability/CVE-2024-32877

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-32877/
Summaries are generated and may contain mistakes; the official description above is the record.
