{"answers":{"affected":"3 open source packages ship an affected version, including social-auth-app-django.","exploited":"There is no known exploitation of CVE-2024-32879 in the wild and no public exploit code.","fix":"Upgrade social-auth-app-django to 5.4.1 or later.","what":"CVE-2024-32879 is a medium-severity authentication bypass vulnerability in python-social-auth social-app-django, published on 24 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-32879 and fix it if it is affected.\n\nWhat it is: CVE-2024-32879 is a medium-severity authentication bypass vulnerability in python-social-auth social-app-django, published on 24 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-32879 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- social-auth-app-django (PyPI): affected all versions; fixed in 5.4.1\n- social-auth-app-django (PyPI): affected all versions; fixed in 5.4.1\n- social-auth-app-django (PyPI): affected all versions; fixed in 5.4.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-32879/ (Markdown: https://insights.sbomify.com/CVE-2024-32879/index.md)","id":"CVE-2024-32879","markdown":"https://insights.sbomify.com/CVE-2024-32879/index.md","name":"CVE-2024-32879","record":{"aliases":["DEBIAN-CVE-2024-32879","GHSA-2gr8-3wc7-xhj3","PYSEC-2026-1931","UBUNTU-CVE-2024-32879","openSUSE-SU-2024:14036-1","openSUSE-SU-2026:12043-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"Python social auth library","requires_auth":"low_privilege","summary":"Attackers can hijack accounts by exploiting case-insensitive database collation to match different user IDs, affecting Python Social Auth users.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":4.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-303","name":"Incorrect Implementation of Authentication Algorithm"},{"id":"CWE-178","name":"Improper Handling of Case Sensitivity"}],"description":"Python Social Auth is a social authentication/registration mechanism. Prior to version 5.4.1, due to default case-insensitive collation in MySQL or MariaDB databases, third-party authentication user IDs are not case-sensitive and could cause different IDs to match. This issue has been addressed by a fix released in version 5.4.1. An immediate workaround would be to change collation of the affected field.","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"social-auth-app-django Improper Handling of Case Sensitivity vulnerability","id":"CVE-2024-32879","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"auth_bypass","year":"2024"},"n_packages":5,"n_references":3,"next":{"headline":"pyLoad allows upload to arbitrary folder lead to RCE","id":"CVE-2024-32880"},"packages":[{"ecosystem":"PyPI","fixed":["5.4.1"],"introduced":["0"],"last_affected":[],"package":"social-auth-app-django","purl":null,"source":"GHSA-2gr8-3wc7-xhj3"},{"ecosystem":"PyPI","fixed":["5.4.1"],"introduced":["0"],"last_affected":[],"package":"social-auth-app-django","purl":"pkg:pypi/social-auth-app-django","source":"GHSA-2gr8-3wc7-xhj3"},{"ecosystem":"PyPI","fixed":["5.4.1"],"introduced":["0"],"last_affected":[],"package":"social-auth-app-django","purl":"pkg:pypi/social-auth-app-django","source":"PYSEC-2026-1931"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["5.4.1-1.1"],"introduced":["0"],"last_affected":[],"package":"python-social-auth-app-django","purl":"pkg:rpm/opensuse/python-social-auth-app-django\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:14036-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["5.9.0-1.2"],"introduced":["0"],"last_affected":[],"package":"python-social-auth-app-django","purl":"pkg:rpm/opensuse/python-social-auth-app-django\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:12043-1"}],"prev":{"headline":"Use of Uninitialized Variable Vulnerability in llama.cpp","id":"CVE-2024-32878"},"products":["social-app-django"],"published":"2024-04-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["python-social-auth"]},"summary":"Attackers can hijack accounts by exploiting case-insensitive database collation to match different user IDs, affecting Python Social Auth users.","url":"https://insights.sbomify.com/CVE-2024-32879/"}