CVE-2024-32882 Permission check bypass when editing a model with per-field restrictions in wagtail
Authenticated users with model edit rights can bypass field-level permission checks to modify restricted fields in Wagtail CMS settings or model viewsets.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-32882?
CVE-2024-32882 is a low-severity missing authorization vulnerability in wagtail, published on 2 May 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Wagtail is an open source content management system built on Django. In affected versions if a model has been made available for editing through the `wagtail.contrib.settings` module or `ModelViewSet`, and the `permission` argument on `FieldPanel` has been used to further restrict access to one or more fields of the model, a user with edit permission over the model but not the specific field can craft an HTTP POST request that bypasses the permission check on the individual field, allowing them to update its value. This vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin, or by a user who has not been granted edit access to the model in question. The editing interfaces for pages and snippets are also unaffected. Patched versions have been released as Wagtail 6.0.3 and 6.1. Wagtail releases prior to 6.0 are unaffected. Users are advised to upgrade. Site owners who are unable to upgrade to a patched version can avoid the vulnerability as follows: 1.For models registered through `ModelViewSet`, register the model as a snippet instead; 2. For settings models, place the restricted fields in a separate settings model, and configure permission at the model level.
Which versions are affected by CVE-2024-32882?
3 open source packages ship an affected version, including wagtail.
| Package | Affected | Fixed in |
|---|---|---|
wagtail PyPI | From 6.0.0 | 6.0.3 |
wagtail PyPI | From 6.0.0 | 6.0.3 |
wagtail PyPI | From 6.0.0 | 6.0.3 |
How do I fix CVE-2024-32882?
Upgrade wagtail to 6.0.3 or later.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2024-32882 being exploited?
There is no known exploitation of CVE-2024-32882 in the wild and no public exploit code.
Sources
Also known as GHSA-w2v8-php4-p8hc, PYSEC-2026-2031.