{"answers":{"affected":"3 open source packages ship an affected version, including wagtail.","exploited":"There is no known exploitation of CVE-2024-32882 in the wild and no public exploit code.","fix":"Upgrade wagtail to 6.0.3 or later.","what":"CVE-2024-32882 is a low-severity missing authorization vulnerability in wagtail, published on 2 May 2024. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-32882 and fix it if it is affected.\n\nWhat it is: CVE-2024-32882 is a low-severity missing authorization vulnerability in wagtail, published on 2 May 2024. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-32882 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wagtail (PyPI): affected from 6.0.0; fixed in 6.0.3\n- wagtail (PyPI): affected from 6.0.0; fixed in 6.0.3\n- wagtail (PyPI): affected from 6.0.0; fixed in 6.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-32882/ (Markdown: https://insights.sbomify.com/CVE-2024-32882/index.md)","id":"CVE-2024-32882","markdown":"https://insights.sbomify.com/CVE-2024-32882/index.md","name":"CVE-2024-32882","record":{"aliases":["GHSA-w2v8-php4-p8hc","PYSEC-2026-2031"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"Wagtail CMS","requires_auth":"high_privilege","summary":"Authenticated users with model edit rights can bypass field-level permission checks to modify restricted fields in Wagtail CMS settings or model viewsets.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":2.7,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-281","name":"Improper Preservation of Permissions"},{"id":"CWE-280","name":"Improper Handling of Insufficient Permissions or Privileges"}],"description":"Wagtail is an open source content management system built on Django. In affected versions if a model has been made available for editing through the `wagtail.contrib.settings` module or `ModelViewSet`, and the `permission` argument on `FieldPanel` has been used to further restrict access to one or more fields of the model, a user with edit permission over the model but not the specific field can craft an HTTP POST request that bypasses the permission check on the individual field, allowing them to update its value. This vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin, or by a user who has not been granted edit access to the model in question. The editing interfaces for pages and snippets are also unaffected. Patched versions have been released as Wagtail 6.0.3 and 6.1. Wagtail releases prior to 6.0 are unaffected. Users are advised to upgrade. Site owners who are unable to upgrade to a patched version can avoid the vulnerability as follows: 1.For models registered through `ModelViewSet`, register the model as a snippet instead; 2. For settings models, place the restricted fields in a separate settings model, and configure permission at the model level.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Permission check bypass when editing a model with per-field restrictions in wagtail","id":"CVE-2024-32882","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"missing_authorization","year":"2024"},"n_packages":3,"n_references":5,"next":{"headline":"MCUboot Injection attack of unprotected TLV values","id":"CVE-2024-32883"},"packages":[{"ecosystem":"PyPI","fixed":["6.0.3"],"introduced":["6.0.0"],"last_affected":[],"package":"wagtail","purl":null,"source":"GHSA-w2v8-php4-p8hc"},{"ecosystem":"PyPI","fixed":["6.0.3"],"introduced":["6.0.0"],"last_affected":[],"package":"wagtail","purl":"pkg:pypi/wagtail","source":"GHSA-w2v8-php4-p8hc"},{"ecosystem":"PyPI","fixed":["6.0.3"],"introduced":["6.0.0"],"last_affected":[],"package":"wagtail","purl":"pkg:pypi/wagtail","source":"PYSEC-2026-2031"}],"prev":{"headline":"Unauthorized access to GET/SET of Slack Bot Tokens in Danswer","id":"CVE-2024-32881"},"products":["wagtail"],"published":"2024-05-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["wagtail"]},"summary":"Authenticated users with model edit rights can bypass field-level permission checks to modify restricted fields in Wagtail CMS settings or model viewsets.","url":"https://insights.sbomify.com/CVE-2024-32882/"}