{"answers":{"affected":"2 open source packages ship an affected version, including sidekiq.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-32887 exists.","fix":"Upgrade sidekiq to 7.2.4 or later.","what":"CVE-2024-32887 is a medium-severity cross-site scripting vulnerability in sidekiq, published on 26 Apr 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-32887 and fix it if it is affected.\n\nWhat it is: CVE-2024-32887 is a medium-severity cross-site scripting vulnerability in sidekiq, published on 26 Apr 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-32887 exists.\n\nAffected packages and fixed versions:\n- sidekiq (RubyGems): affected from 7.2.0; fixed in 7.2.4\n- sidekiq (RubyGems): affected from 7.2.0; fixed in 7.2.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-32887/ (Markdown: https://insights.sbomify.com/CVE-2024-32887/index.md)","id":"CVE-2024-32887","markdown":"https://insights.sbomify.com/CVE-2024-32887/index.md","name":"CVE-2024-32887","record":{"aliases":["GHSA-q655-3pj8-9fxq"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_read","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby background processing library","requires_auth":"low_privilege","summary":"Attackers can inject JavaScript into the Sidekiq Web UI via the substr parameter, potentially compromising user accounts and data.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Sidekiq is simple, efficient background processing for Ruby. Sidekiq is reflected XSS vulnerability. The value of substr parameter is reflected in the response without any encoding, allowing an attacker to inject Javascript code into the response of the application.  An attacker could exploit it to target users of the Sidekiq Web UI. Moreover, if other applications are deployed on the same domain or website as Sidekiq, users of those applications could also be affected, leading to a broader scope of compromise. Potentially compromising their accounts, forcing the users to perform sensitive actions, stealing sensitive data, performing CORS attacks, defacement of the web application, etc. This issue has been patched in version 7.2.4.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Reflected XSS in sidekiq","id":"CVE-2024-32887","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":3,"next":{"headline":"Amazon JDBC Driver for Redshift SQL Injection via line comment generation","id":"CVE-2024-32888"},"packages":[{"ecosystem":"RubyGems","fixed":["7.2.4"],"introduced":["7.2.0"],"last_affected":[],"package":"sidekiq","purl":null,"source":"GHSA-q655-3pj8-9fxq"},{"ecosystem":"RubyGems","fixed":["7.2.4"],"introduced":["7.2.0"],"last_affected":[],"package":"sidekiq","purl":"pkg:gem/sidekiq","source":"GHSA-q655-3pj8-9fxq"}],"prev":{"headline":"Vitess vulnerable to infinite memory consumption and vtgate crash","id":"CVE-2024-32886"},"products":["sidekiq"],"published":"2024-04-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["sidekiq"]},"summary":"Attackers can inject JavaScript into the Sidekiq Web UI via the substr parameter, potentially compromising user accounts and data.","url":"https://insights.sbomify.com/CVE-2024-32887/"}