CVE-2024-32939 Email addresses of remote users visible in props regardless of server settings

Medium 4.3 Published Updated

Attackers can view remote users' email addresses in shared channels even when server settings hide them, exposing sensitive user data.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-32939?

CVE-2024-32939 is a medium-severity vulnerability in Mattermost Mattermost, published on 22 Aug 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Mattermost versions 9.9.x <= 9.9.1, 9.5.x <= 9.5.7, 9.10.x <= 9.10.0, 9.8.x <= 9.8.2, when shared channels are enabled, fail to redact remote users' original email addresses stored in user props when email addresses are otherwise configured not to be visible in the local server."

Weakness: CWE-312, CWE-284

Which versions are affected by CVE-2024-32939?

12 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost/server/v8 GoAll versionsNone
github.com/mattermost/mattermost/server/v8 GoFrom 9.10.09.10.1
github.com/mattermost/mattermost/server/v8 GoFrom 9.10.09.10.1
github.com/mattermost/mattermost/server/v8 GoFrom 9.5.09.5.8
github.com/mattermost/mattermost/server/v8 GoFrom 9.5.09.5.8
github.com/mattermost/mattermost/server/v8 GoFrom 9.8.09.8.3
6 more packages
github.com/mattermost/mattermost/server/v8 GoFrom 9.8.09.8.3
github.com/mattermost/mattermost/server/v8 GoFrom 9.9.09.9.2
github.com/mattermost/mattermost/server/v8 GoFrom 9.9.09.9.2
github.com/mattermost/mattermost-server GoFrom 9.5.0+incompatible9.5.8+incompatible, 9.8.3+incompatible, 9.9.2+incompatible, 9.10.1+incompatible
github.com/mattermost/mattermost-server/v5 GoAll versionsNone
github.com/mattermost/mattermost-server/v6 GoAll versionsNone

Products include Mattermost Mattermost.

How do I fix CVE-2024-32939?

Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 9.10.1, 9.5.8, 9.8.3 or 9.9.2.

Is CVE-2024-32939 being exploited?

There is no known exploitation of CVE-2024-32939 in the wild and no public exploit code.

All Mattermost Mattermost vulnerabilities

Sources

Also known as GHSA-4ww8-fprq-cq34, GO-2024-3093.

Is CVE-2024-32939 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free