# CVE-2024-32962: XML signature verification bypass due improper verification of signature / signature spoofing

> Attackers can bypass XML signature verification by spoofing certificates in KeyInfo, allowing unauthorized document acceptance in xml-crypto.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 May 2024
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-2xp3-57p7-qf4v

## What is CVE-2024-32962?

CVE-2024-32962 is a critical vulnerability in node-saml xml-crypto, published on 2 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

xml-crypto is an xml digital signature and encryption library for Node.js. In affected versions the default configuration does not check authorization of the signer, it only checks the validity of the signature per section 3.2.2 of the w3 xmldsig-core-20080610 spec. As such, without additional validation steps, the default configuration allows a malicious actor to re-sign an XML document, place the certificate in a `<KeyInfo />` element, and pass `xml-crypto` default validation checks. As a result `xml-crypto` trusts by default any certificate provided via digitally signed XML document's `<KeyInfo />`. `xml-crypto` prefers to use any certificate provided via digitally signed XML document's `<KeyInfo />` even if library was configured to use specific certificate (`publicCert`) for signature verification purposes.  An attacker can spoof signature verification by modifying XML document and replacing existing signature with signature generated with malicious private key (created by attacker) and by attaching that private key's certificate to `<KeyInfo />` element. This vulnerability is combination of changes introduced to `4.0.0` on pull request 301 / commit `c2b83f98` and has been addressed in version 6.0.0 with pull request 445 / commit `21201723d`. Users are advised to upgrade. Users unable to upgrade may either check the certificate extracted via `getCertFromKeyInfo` against trusted certificates before accepting the results of the validation or set `xml-crypto's getCertFromKeyInfo` to `() => undefined` forcing `xml-crypto` to use an explicitly configured `publicCert` or `privateKey` for signature verification.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2024-32962?

2 open source packages ship an affected version, including xml-crypto.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `xml-crypto` | npm | From 4.0.0 | 6.0.0 |
| `xml-crypto` | npm | From 4.0.0 | 6.0.0 |

## How do I fix CVE-2024-32962?

Upgrade xml-crypto to 6.0.0 or later.

## Is CVE-2024-32962 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-32962 exists.

Public exploit code:

- https://github.com/absholi7ly/Poc-CVE-2024-32962-xml-crypto (github_poc): https://github.com/absholi7ly/Poc-CVE-2024-32962-xml-crypto

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-32962 and fix it if it is affected.

What it is: CVE-2024-32962 is a critical vulnerability in node-saml xml-crypto, published on 2 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-32962 exists.

Affected packages and fixed versions:
- xml-crypto (npm): affected from 4.0.0; fixed in 6.0.0
- xml-crypto (npm): affected from 4.0.0; fixed in 6.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-32962/ (Markdown: https://insights.sbomify.com/CVE-2024-32962/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-32962
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-32962
- OSV: https://osv.dev/vulnerability/CVE-2024-32962

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-32962/
Summaries are generated and may contain mistakes; the official description above is the record.
