# CVE-2024-32963: Parameter Tampering vulnerability in Navidrome

> Attackers can impersonate other users by tampering with HTTP request parameters, allowing unauthorized modification of playlists and comments.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-4jrx-5w4h-3gpm, GO-2024-2803

## What is CVE-2024-32963?

CVE-2024-32963 is a medium-severity vulnerability in navidrome, published on 1 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Navidrome is an open source web-based music collection server and streamer. In affected versions of Navidrome are subject to a parameter tampering vulnerability where an attacker has the ability to manipulate parameter values in the HTTP requests. The attacker is able to change the parameter values in the body and successfully impersonate another user. In this case, the attacker created a playlist, added song, posted arbitrary comment, set the playlist to be public, and put the admin as the owner of the playlist. The attacker must be able to intercept http traffic for this attack. Each known user is impacted. An attacker can obtain the ownerId from shared playlist information, meaning every user who has shared a playlist is also impacted, as they can be impersonated. This issue has been addressed in version 0.52.0 and users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2024-32963?

3 open source packages ship an affected version, including github.com/navidrome/navidrome. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/navidrome/navidrome` | Go | All versions | 0.52.0 |
| `github.com/navidrome/navidrome` | Go | All versions | 0.52.0 |
| `github.com/navidrome/navidrome` | Go | All versions | 0.52.0 |

Products: Navidrome Navidrome.

## How do I fix CVE-2024-32963?

Upgrade github.com/navidrome/navidrome to 0.52.0 or later.

## Is CVE-2024-32963 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-32963 exists.

## Other vulnerabilities in navidrome

- [CVE-2024-47062](https://insights.sbomify.com/CVE-2024-47062/): Multiple SQL Injections and ORM Leak in navidrome (critical 9.4)
- [CVE-2026-25579](https://insights.sbomify.com/CVE-2026-25579/): Navidrome affected by Denial of Service and disk exhaustion via oversized `size` parameter in `/rest/getCoverArt` and `/share/img/<token>` endpoints (critical 9.2)
- [CVE-2024-41259](https://insights.sbomify.com/CVE-2024-41259/): Navidrome uses MD5 hashing algorithm (critical 9.1)
- [CVE-2025-48949](https://insights.sbomify.com/CVE-2025-48949/): Navidrome allows SQL Injection via role parameter (high 8.9)
- [CVE-2023-51442](https://insights.sbomify.com/CVE-2023-51442/): Authentication bypass vulnerability in navidrome's subsonic endpoint (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-32963 and fix it if it is affected.

What it is: CVE-2024-32963 is a medium-severity vulnerability in navidrome, published on 1 May 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-32963 exists.

Affected packages and fixed versions:
- github.com/navidrome/navidrome (Go): affected all versions; fixed in 0.52.0
- github.com/navidrome/navidrome (Go): affected all versions; fixed in 0.52.0
- github.com/navidrome/navidrome (Go): affected all versions; fixed in 0.52.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-32963/ (Markdown: https://insights.sbomify.com/CVE-2024-32963/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-32963
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-32963
- OSV: https://osv.dev/vulnerability/CVE-2024-32963

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-32963/
Summaries are generated and may contain mistakes; the official description above is the record.
