# CVE-2024-32964: lobe-chat `/api/proxy` endpoint Server-Side Request Forgery vulnerability

> An attacker can exploit an unauthorized SSRF vulnerability in the /api/proxy endpoint to access intranet services and leak sensitive information.

- **Severity:** Critical 9.0 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-mxhq-xw3g-rphc

## What is CVE-2024-32964?

CVE-2024-32964 is a critical server-side request forgery vulnerability in lobehub lobe-chat, published on 10 May 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Lobe Chat is a chatbot framework that supports speech synthesis, multimodal, and extensible Function Call plugin system. Prior to 0.150.6, lobe-chat had an unauthorized Server-Side Request Forgery vulnerability in the /api/proxy endpoint. An attacker can construct malicious requests to cause Server-Side Request Forgery without logging in, attack intranet services, and leak sensitive information.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2024-32964?

2 open source packages ship an affected version, including @lobehub/chat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@lobehub/chat` | npm | All versions | 0.150.6 |
| `@lobehub/chat` | npm | All versions | 0.150.6 |

Products: Lobehub Lobe Chat.

## How do I fix CVE-2024-32964?

Upgrade @lobehub/chat to 0.150.6 or later.

## Is CVE-2024-32964 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-32964 exists.

Public exploit code:

- Lobe Chat <= v0.150.5 - Server-Side Request Forgery (nuclei): http/cves/2024/CVE-2024-32964.yaml

## Other vulnerabilities in lobehub lobe-chat

- [CVE-2024-47066](https://insights.sbomify.com/CVE-2024-47066/): Lobe Chat has insufficient fix for GHSA-mxhq-xw3g-rphc (CVE-2024-32964) (critical 9.0)
- [CVE-2024-32965](https://insights.sbomify.com/CVE-2024-32965/): ssrf vulnerability in lobe-chat (high 8.1)
- [CVE-2025-59417](https://insights.sbomify.com/CVE-2025-59417/): Lobe Chat Desktop Vulnerable to Remote Code Execution via XSS in Chat Messages (medium 6.8)
- [CVE-2024-37895](https://insights.sbomify.com/CVE-2024-37895/): API Key Leak in lobe-chat (medium 5.7)
- [CVE-2024-24566](https://insights.sbomify.com/CVE-2024-24566/): Lobe Chat unauthorized access to plugins (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-32964 and fix it if it is affected.

What it is: CVE-2024-32964 is a critical server-side request forgery vulnerability in lobehub lobe-chat, published on 10 May 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-32964 exists.

Affected packages and fixed versions:
- @lobehub/chat (npm): affected all versions; fixed in 0.150.6
- @lobehub/chat (npm): affected all versions; fixed in 0.150.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-32964/ (Markdown: https://insights.sbomify.com/CVE-2024-32964/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-32964
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-32964
- OSV: https://osv.dev/vulnerability/CVE-2024-32964

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-32964/
Summaries are generated and may contain mistakes; the official description above is the record.
