{"answers":{"affected":"2 open source packages ship an affected version, including @lobehub/chat. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-32965 exists.","fix":"Upgrade @lobehub/chat to 1.19.13 or later.","what":"CVE-2024-32965 is a high-severity server-side request forgery vulnerability in lobehub lobe-chat, published on 26 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-32965 and fix it if it is affected.\n\nWhat it is: CVE-2024-32965 is a high-severity server-side request forgery vulnerability in lobehub lobe-chat, published on 26 Nov 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-32965 exists.\n\nAffected packages and fixed versions:\n- @lobehub/chat (npm): affected all versions; fixed in 1.19.13\n- @lobehub/chat (npm): affected all versions; fixed in 1.19.13\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-32965/ (Markdown: https://insights.sbomify.com/CVE-2024-32965/index.md)","id":"CVE-2024-32965","markdown":"https://insights.sbomify.com/CVE-2024-32965/index.md","name":"CVE-2024-32965","record":{"aliases":["GHSA-2xcc-vm3f-m8rw"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"AI chat framework","requires_auth":"none","summary":"Unauthenticated attackers can exploit SSRF in Lobe Chat to scan internal networks and leak sensitive information by modifying proxy headers.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"lobe_chat","vendor":"lobehub"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"Lobe Chat is an open-source, AI chat framework. Versions of lobe-chat prior to 1.19.13 have an unauthorized ssrf vulnerability. An attacker can construct malicious requests to cause SSRF without logging in, attack intranet services, and leak sensitive information. The jwt token header X-Lobe-Chat-Auth strored proxy address and OpenAI API Key, can be modified to scan an internal network in the target lobe-web environment. This issue has been addressed in release version 1.19.13 and all users are advised to upgrade. There are no known workarounds for this vulnerability.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"ssrf vulnerability in lobe-chat","id":"CVE-2024-32965","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"ssrf","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Stored Cross-site Scripting in directory listings via file names in static-web-server","id":"CVE-2024-32966"},"packages":[{"ecosystem":"npm","fixed":["1.19.13"],"introduced":["0"],"last_affected":[],"package":"@lobehub/chat","purl":null,"source":"GHSA-2xcc-vm3f-m8rw"},{"ecosystem":"npm","fixed":["1.19.13"],"introduced":["0"],"last_affected":[],"package":"@lobehub/chat","purl":"pkg:npm/%40lobehub/chat","source":"GHSA-2xcc-vm3f-m8rw"}],"prev":{"headline":"lobe-chat `/api/proxy` endpoint Server-Side Request Forgery vulnerability","id":"CVE-2024-32964"},"products":["lobe-chat"],"published":"2024-11-26","related":[{"cvss_score":9,"headline":"Lobe Chat has insufficient fix for GHSA-mxhq-xw3g-rphc (CVE-2024-32964)","id":"CVE-2024-47066","kev_date_added":null,"published":"2024-09-23"},{"cvss_score":9,"headline":"lobe-chat `/api/proxy` endpoint Server-Side Request Forgery vulnerability","id":"CVE-2024-32964","kev_date_added":null,"published":"2024-05-10"},{"cvss_score":6.8,"headline":"Lobe Chat Desktop Vulnerable to Remote Code Execution via XSS in Chat Messages","id":"CVE-2025-59417","kev_date_added":null,"published":"2025-09-18"},{"cvss_score":5.7,"headline":"API Key Leak in lobe-chat","id":"CVE-2024-37895","kev_date_added":null,"published":"2024-06-17"},{"cvss_score":5.3,"headline":"Lobe Chat unauthorized access to plugins","id":"CVE-2024-24566","kev_date_added":null,"published":"2024-01-31"},{"cvss_score":4.3,"headline":"lobe-chat has an Open Redirect","id":"CVE-2025-59426","kev_date_added":null,"published":"2025-09-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-26","vendors":["lobehub"]},"summary":"Unauthenticated attackers can exploit SSRF in Lobe Chat to scan internal networks and leak sensitive information by modifying proxy headers.","url":"https://insights.sbomify.com/CVE-2024-32965/"}