# CVE-2024-32969: vantage6 collaboration admins can extend their influence by expanding the collaboration

> Collaboration administrators can add organizations to expand influence, allowing them to read task results from other collaborations via created users.

- **Severity:** Low 2.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-99r4-cjp4-3hmx, PYSEC-2026-2007

## What is CVE-2024-32969?

CVE-2024-32969 is a low-severity vulnerability in vantage6, published on 23 May 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

vantage6 is an open-source infrastructure for privacy preserving analysis. Collaboration administrators can add extra organizations to their collaboration that can extend their influence. For example, organizations that they include can then create new users for which they know the passwords, and use that to read task results of other collaborations that that organization is involved in.  This is only relatively trusted users - with access to manage a collaboration - are able to do this, which reduces the impact. This vulnerability was patched in version 4.5.0rc3.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2024-32969?

3 open source packages ship an affected version, including vantage6.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vantage6` | PyPI | All versions | 4.5.0rc3 |
| `vantage6` | PyPI | All versions | 4.5.0rc3 |
| `vantage6` | PyPI | All versions | 4.5.0rc3 |

## How do I fix CVE-2024-32969?

Upgrade vantage6 to 4.5.0rc3 or later.

## Is CVE-2024-32969 being exploited?

There is no known exploitation of CVE-2024-32969 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-32969 and fix it if it is affected.

What it is: CVE-2024-32969 is a low-severity vulnerability in vantage6, published on 23 May 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-32969 in the wild and no public exploit code.

Affected packages and fixed versions:
- vantage6 (PyPI): affected all versions; fixed in 4.5.0rc3
- vantage6 (PyPI): affected all versions; fixed in 4.5.0rc3
- vantage6 (PyPI): affected all versions; fixed in 4.5.0rc3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-32969/ (Markdown: https://insights.sbomify.com/CVE-2024-32969/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-32969
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-32969
- OSV: https://osv.dev/vulnerability/CVE-2024-32969

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-32969/
Summaries are generated and may contain mistakes; the official description above is the record.
