CVE-2024-32971 Defect in query plan cache may cause incorrect operations to be executed in Apollo Router
Apollo Router may execute incorrect GraphQL operations due to a cache defect, leading to unintended data access or modifications when distributed caching is enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-32971?
CVE-2024-32971 is a critical vulnerability in apollographql router, published on 2 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Apollo Router is a configurable, graph router written in Rust to run a federated supergraph that uses Apollo Federation 2. The affected versions of Apollo Router contain a bug that in limited circumstances, could lead to unexpected operations being executed which can result in unintended data or effects. This only affects Router instances configured to use distributed query plan caching. The root cause of this defect is a bug in Apollo Router’s cache retrieval logic: When this defect is present and distributed query planning caching is enabled, asking the Router to execute an operation (whether it is a query, a mutation, or a subscription) may result in an unexpected variation of that operation being executed or the generation of unexpected errors. The issue stems from inadvertently executing a modified version of a previously executed operation, whose query plan is stored in the underlying cache (specifically, Redis). Depending on the type of the operation, the result may vary. For a query, results may be fetched that don’t match what was requested (e.g., rather than running `fetchUsers(type: ENTERPRISE)` the Router may run `fetchUsers(type: TRIAL)`. For a mutation, this may result in incorrect mutations being sent to underlying subgraph servers (e.g., rather than sending `deleteUser(id: 10)` to a subgraph, the Router may run `deleteUser(id: 12)`. Users who are using distributed query plan caching, are advised to either upgrade to version 1.45.1 or above or downgrade to version 1.43.2 of the Apollo Router. Apollo Router versions 1.44.0 or 1.45.0 are not recommended for use and have been withdrawn. Users unable to upgrade can disable distributed query plan caching to mitigate this issue.
Which versions are affected by CVE-2024-32971?
2 open source packages ship an affected version, including apollo-router.
| Package | Affected | Fixed in |
|---|---|---|
apollo-router crates.io | From 1.44.0 | 1.45.1 |
apollo-router crates.io | From 1.44.0 | 1.45.1 |
How do I fix CVE-2024-32971?
Upgrade apollo-router to 1.45.1 or later.
Is CVE-2024-32971 being exploited?
There is no known exploitation of CVE-2024-32971 in the wild and no public exploit code.
Sources
Also known as GHSA-q9p4-hw9m-fj2v.