# CVE-2024-32972: go-ethereum denial of service via malicious p2p message

> An attacker can cause a go-ethereum node to consume excessive memory via crafted p2p messages, leading to denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-4xc9-8hmq-j652, GO-2024-2819

## What is CVE-2024-32972?

CVE-2024-32972 is a high-severity denial of service vulnerability in go-ethereum, published on 6 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

go-ethereum (geth) is a golang execution layer implementation of the Ethereum protocol. Prior to 1.13.15, a vulnerable node can be made to consume very large amounts of memory when handling specially crafted p2p messages sent from an attacker node. The fix has been included in geth version `1.13.15` and onwards.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2024-32972?

3 open source packages ship an affected version, including github.com/ethereum/go-ethereum.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/ethereum/go-ethereum` | Go | All versions | 1.13.15 |
| `github.com/ethereum/go-ethereum` | Go | All versions | 1.13.15 |
| `github.com/ethereum/go-ethereum` | Go | All versions | 1.13.15 |

## How do I fix CVE-2024-32972?

Upgrade github.com/ethereum/go-ethereum to 1.13.15 or later.

## Is CVE-2024-32972 being exploited?

There is no known exploitation of CVE-2024-32972 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-32972 and fix it if it is affected.

What it is: CVE-2024-32972 is a high-severity denial of service vulnerability in go-ethereum, published on 6 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-32972 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/ethereum/go-ethereum (Go): affected all versions; fixed in 1.13.15
- github.com/ethereum/go-ethereum (Go): affected all versions; fixed in 1.13.15
- github.com/ethereum/go-ethereum (Go): affected all versions; fixed in 1.13.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-32972/ (Markdown: https://insights.sbomify.com/CVE-2024-32972/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-32972
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-32972
- OSV: https://osv.dev/vulnerability/CVE-2024-32972

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-32972/
Summaries are generated and may contain mistakes; the official description above is the record.
