# CVE-2024-32977: OctoPrint Authentication Bypass via X-Forwarded-For Header when autologinLocal is enabled

> Attackers can bypass authentication in OctoPrint by spoofing IP headers when autologinLocal is enabled, allowing unauthorized access to the 3D printer control interface.

- **Severity:** High 7.1 (`CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-2vjq-hg5w-5gm7, PYSEC-2024-237

## What is CVE-2024-32977?

CVE-2024-32977 is a high-severity authentication bypass vulnerability in OctoPrint, published on 14 May 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

OctoPrint provides a web interface for controlling consumer 3D printers. OctoPrint versions up until and including 1.10.0 contain a vulnerability that allows an unauthenticated attacker to completely bypass the authentication if the `autologinLocal` option is enabled within `config.yaml`, even if they come from networks that are not configured as `localNetworks`, spoofing their IP via the `X-Forwarded-For` header. If autologin is not enabled, this vulnerability does not have any impact. The vulnerability has been patched in version 1.10.1. Until the patch has been applied, OctoPrint administrators who have autologin enabled on their instances should disable it and/or to make the instance inaccessible from potentially hostile networks like the internet.

Weakness: CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2024-32977?

3 open source packages ship an affected version, including octoprint and OctoPrint. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `octoprint` | PyPI | All versions | 1.10.1 |
| `octoprint` | PyPI | All versions | 1.10.1 |
| `OctoPrint` | PyPI | All versions | 1.10.1 |

Products: Octoprint Octoprint.

## How do I fix CVE-2024-32977?

Upgrade octoprint to 1.10.1 or later.

## Is CVE-2024-32977 being exploited?

There is no known exploitation of CVE-2024-32977 in the wild and no public exploit code.

## Other vulnerabilities in OctoPrint

- [CVE-2018-16710](https://insights.sbomify.com/CVE-2018-16710/): Information disclosure in n/a (critical 9.1)
- [CVE-2025-58180](https://insights.sbomify.com/CVE-2025-58180/): OctoPrint is Vulnerable to RCE Attacks via Unsanitized Filename in File Upload (high 7.5)
- [CVE-2022-1430](https://insights.sbomify.com/CVE-2022-1430/): Cross-site Scripting (XSS) - DOM in octoprint/octoprint (high 7.5)
- [CVE-2022-1432](https://insights.sbomify.com/CVE-2022-1432/): Cross-site Scripting (XSS) - Generic in octoprint/octoprint (high 7.5)
- [CVE-2025-48879](https://insights.sbomify.com/CVE-2025-48879/): OctoPrint Vulnerable to Denial of Service through malformed HTTP request (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-32977 and fix it if it is affected.

What it is: CVE-2024-32977 is a high-severity authentication bypass vulnerability in OctoPrint, published on 14 May 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-32977 in the wild and no public exploit code.

Affected packages and fixed versions:
- octoprint (PyPI): affected all versions; fixed in 1.10.1
- octoprint (PyPI): affected all versions; fixed in 1.10.1
- OctoPrint (PyPI): affected all versions; fixed in 1.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-32977/ (Markdown: https://insights.sbomify.com/CVE-2024-32977/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-32977
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-32977
- OSV: https://osv.dev/vulnerability/CVE-2024-32977

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-32977/
Summaries are generated and may contain mistakes; the official description above is the record.
