{"answers":{"affected":"2 open source packages ship an affected version, including kaminari.","exploited":"There is no known exploitation of CVE-2024-32978 in the wild and no public exploit code.","fix":"Upgrade kaminari to 0.16.2 or later.","what":"CVE-2024-32978 is a medium-severity vulnerability in kaminari, published on 27 May 2024. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-32978 and fix it if it is affected.\n\nWhat it is: CVE-2024-32978 is a medium-severity vulnerability in kaminari, published on 27 May 2024. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-32978 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- kaminari (RubyGems): affected from 0.15.0; fixed in 0.16.2\n- kaminari (RubyGems): affected from 0.15.0; fixed in 0.16.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-32978/ (Markdown: https://insights.sbomify.com/CVE-2024-32978/index.md)","id":"CVE-2024-32978","markdown":"https://insights.sbomify.com/CVE-2024-32978/index.md","name":"CVE-2024-32978","record":{"aliases":["GHSA-7r3j-qmr4-jfpj","UBUNTU-CVE-2024-32978"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby pagination library","requires_auth":"high_privilege","summary":"Insecure file permissions in the Kaminari Ruby library allow unauthorized users to modify Ruby files, potentially altering application behavior or executing code.","user_interaction":"not_required","vuln_class":"misconfiguration"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.6,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-276","name":"Incorrect Default Permissions"}],"description":"Kaminari is a paginator for web app frameworks and object relational mappings. A security vulnerability involving insecure file permissions has been identified in the Kaminari pagination library for Ruby on Rails, concerning insecure file permissions. This vulnerability is of moderate severity due to the potential for unauthorized write access to particular Ruby files managed by the library. Such access could lead to the alteration of application behavior or data integrity issues. Users of affected versions are advised to update to Kaminari version 0.16.2 or later, where file permissions have been adjusted to enhance security. If upgrading is not feasible immediately, review and adjust the file permissions for particular Ruby files in Kaminari to ensure they are only accessible by authorized user.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Kaminari Insecure File Permissions Vulnerability","id":"CVE-2024-32978","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"misconfiguration","year":"2024"},"n_packages":2,"n_references":1,"next":{"headline":"Reflected Cross-site Scripting potential in all object list views in Nautobot","id":"CVE-2024-32979"},"packages":[{"ecosystem":"RubyGems","fixed":["0.16.2"],"introduced":["0.15.0"],"last_affected":[],"package":"kaminari","purl":null,"source":"GHSA-7r3j-qmr4-jfpj"},{"ecosystem":"RubyGems","fixed":["0.16.2"],"introduced":["0.15.0"],"last_affected":[],"package":"kaminari","purl":"pkg:gem/kaminari","source":"GHSA-7r3j-qmr4-jfpj"}],"prev":{"headline":"OctoPrint Authentication Bypass via X-Forwarded-For Header when autologinLocal is enabled","id":"CVE-2024-32977"},"products":["kaminari"],"published":"2024-05-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-08-02","vendors":["kaminari"]},"summary":"Insecure file permissions in the Kaminari Ruby library allow unauthorized users to modify Ruby files, potentially altering application behavior or executing code.","url":"https://insights.sbomify.com/CVE-2024-32978/"}