# CVE-2024-32978: Kaminari Insecure File Permissions Vulnerability

> Insecure file permissions in the Kaminari Ruby library allow unauthorized users to modify Ruby files, potentially altering application behavior or executing code.

- **Severity:** Medium 6.6 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-7r3j-qmr4-jfpj, UBUNTU-CVE-2024-32978

## What is CVE-2024-32978?

CVE-2024-32978 is a medium-severity vulnerability in kaminari, published on 27 May 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Kaminari is a paginator for web app frameworks and object relational mappings. A security vulnerability involving insecure file permissions has been identified in the Kaminari pagination library for Ruby on Rails, concerning insecure file permissions. This vulnerability is of moderate severity due to the potential for unauthorized write access to particular Ruby files managed by the library. Such access could lead to the alteration of application behavior or data integrity issues. Users of affected versions are advised to update to Kaminari version 0.16.2 or later, where file permissions have been adjusted to enhance security. If upgrading is not feasible immediately, review and adjust the file permissions for particular Ruby files in Kaminari to ensure they are only accessible by authorized user.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2024-32978?

2 open source packages ship an affected version, including kaminari.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kaminari` | RubyGems | From 0.15.0 | 0.16.2 |
| `kaminari` | RubyGems | From 0.15.0 | 0.16.2 |

## How do I fix CVE-2024-32978?

Upgrade kaminari to 0.16.2 or later.

## Is CVE-2024-32978 being exploited?

There is no known exploitation of CVE-2024-32978 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-32978 and fix it if it is affected.

What it is: CVE-2024-32978 is a medium-severity vulnerability in kaminari, published on 27 May 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-32978 in the wild and no public exploit code.

Affected packages and fixed versions:
- kaminari (RubyGems): affected from 0.15.0; fixed in 0.16.2
- kaminari (RubyGems): affected from 0.15.0; fixed in 0.16.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-32978/ (Markdown: https://insights.sbomify.com/CVE-2024-32978/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-32978
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-32978
- OSV: https://osv.dev/vulnerability/CVE-2024-32978

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-32978/
Summaries are generated and may contain mistakes; the official description above is the record.
