# CVE-2024-32981: Cross-site Scripting vulnerability with encoded payload in silverstripe/framework

> An attacker with CMS edit access can inject JavaScript via encoded payloads bypassing server-side sanitization, requiring an upgrade to Silverstripe framework.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jul 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-chx7-9x8h-r5mg

## What is CVE-2024-32981?

CVE-2024-32981 is a medium-severity cross-site scripting vulnerability in silverstripe-framework, published on 17 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Silverstripe framework is the PHP framework forming the base for the Silverstripe CMS. In affected versions a bad actor with access to edit content in the CMS could add send a specifically crafted encoded payload to the server, which could be used to inject a JavaScript payload on the front end of the site. The payload would be sanitised on the client-side, but server-side sanitisation doesn't catch it. The server-side sanitisation logic has been updated to sanitise against this type of attack in version 5.2.16. All users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-32981?

2 open source packages ship an affected version, including silverstripe/framework. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `silverstripe/framework` | Packagist | All versions | 5.2.16 |
| `silverstripe/framework` | Packagist | All versions | 5.2.16 |

Products: Silverstripe Framework.

## How do I fix CVE-2024-32981?

Upgrade silverstripe/framework to 5.2.16 or later.

## Is CVE-2024-32981 being exploited?

There is no known exploitation of CVE-2024-32981 in the wild and no public exploit code.

## Other vulnerabilities in silverstripe-framework

- [CVE-2022-38148](https://insights.sbomify.com/CVE-2022-38148/): Blind SQL Injection via GridFieldSortableHeader (high 8.8)
- [CVE-2022-38462](https://insights.sbomify.com/CVE-2022-38462/): Reflected XSS in querystring parameters (medium 6.1)
- [CVE-2025-30148](https://insights.sbomify.com/CVE-2025-30148/): Silverstripe Framework has a XSS vulnerability in HTML editor (medium 5.4)
- [CVE-2024-53277](https://insights.sbomify.com/CVE-2024-53277/): Cross-site Scripting in form messages in silverstripe framework (medium 5.4)
- [CVE-2023-22729](https://insights.sbomify.com/CVE-2023-22729/): Silverstripe Framework has open redirect vulnerability on CMSSecurity relogin screen (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-32981 and fix it if it is affected.

What it is: CVE-2024-32981 is a medium-severity cross-site scripting vulnerability in silverstripe-framework, published on 17 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-32981 in the wild and no public exploit code.

Affected packages and fixed versions:
- silverstripe/framework (Packagist): affected all versions; fixed in 5.2.16
- silverstripe/framework (Packagist): affected all versions; fixed in 5.2.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-32981/ (Markdown: https://insights.sbomify.com/CVE-2024-32981/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-32981
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-32981
- OSV: https://osv.dev/vulnerability/CVE-2024-32981

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-32981/
Summaries are generated and may contain mistakes; the official description above is the record.
