CVE-2024-32982 Litestar and Starlite affected by Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
Attackers can exploit path traversal in Litestar's static file serving to access sensitive files outside designated directories, leading to information disclosure.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-32982?
CVE-2024-32982 is a high-severity path traversal vulnerability in litestar-org litestar, published on 6 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Litestar and Starlite is an Asynchronous Server Gateway Interface (ASGI) framework. Prior to 2.8.3, 2.7.2, and 2.6.4, a Local File Inclusion (LFI) vulnerability has been discovered in the static file serving component of LiteStar. This vulnerability allows attackers to exploit path traversal flaws, enabling unauthorized access to sensitive files outside the designated directories. Such access can lead to the disclosure of sensitive information or potentially compromise the server. The vulnerability is located in the file path handling mechanism within the static content serving function, specifically at `litestar/static_files/base.py`. This vulnerability is fixed in versions 2.8.3, 2.7.2, and 2.6.4.
Weakness: CWE-22
Which versions are affected by CVE-2024-32982?
10 open source packages ship an affected version, including litestar and starlite.
| Package | Affected | Fixed in |
|---|---|---|
litestar PyPI | From 2.0.0 | 2.6.4, 2.7.2, 2.8.3 |
litestar PyPI | From 2.0.0 | 2.6.4 |
litestar PyPI | From 2.0.0 | 2.6.4 |
litestar PyPI | From 2.7.0 | 2.7.2 |
litestar PyPI | From 2.7.0 | 2.7.2 |
litestar PyPI | From 2.8.0 | 2.8.3 |
4 more packages
litestar PyPI | From 2.8.0 | 2.8.3 |
starlite PyPI | From 1.37.0 | 1.51.16 |
starlite PyPI | From 1.37.0 | 1.51.16 |
starlite PyPI | From 1.37.0 | 1.51.16 |
How do I fix CVE-2024-32982?
Upgrade litestar to a fixed version for your release line: 2.6.4, 2.7.2 or 2.8.3.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2024-32982 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-32982 exists.
Sources
Also known as GHSA-83pv-qr33-2vcf, PYSEC-2026-1552, PYSEC-2026-2605.