# CVE-2024-32982: Litestar and Starlite affected by Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

> Attackers can exploit path traversal in Litestar's static file serving to access sensitive files outside designated directories, leading to information disclosure.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 May 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-83pv-qr33-2vcf, PYSEC-2026-1552, PYSEC-2026-2605

## What is CVE-2024-32982?

CVE-2024-32982 is a high-severity path traversal vulnerability in litestar-org litestar, published on 6 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Litestar and Starlite is an Asynchronous Server Gateway Interface (ASGI) framework. Prior to 2.8.3, 2.7.2, and 2.6.4, a Local File Inclusion (LFI) vulnerability has been discovered in the static file serving component of LiteStar. This vulnerability allows attackers to exploit path traversal flaws, enabling unauthorized access to sensitive files outside the designated directories. Such access can lead to the disclosure of sensitive information or potentially compromise the server. The vulnerability is located in the file path handling mechanism within the static content serving function, specifically at `litestar/static_files/base.py`. This vulnerability is fixed in versions 2.8.3, 2.7.2, and 2.6.4.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-32982?

10 open source packages ship an affected version, including litestar and starlite.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `litestar` | PyPI | From 2.0.0 | 2.6.4, 2.7.2, 2.8.3 |
| `litestar` | PyPI | From 2.0.0 | 2.6.4 |
| `litestar` | PyPI | From 2.0.0 | 2.6.4 |
| `litestar` | PyPI | From 2.7.0 | 2.7.2 |
| `litestar` | PyPI | From 2.7.0 | 2.7.2 |
| `litestar` | PyPI | From 2.8.0 | 2.8.3 |
| `litestar` | PyPI | From 2.8.0 | 2.8.3 |
| `starlite` | PyPI | From 1.37.0 | 1.51.16 |
| `starlite` | PyPI | From 1.37.0 | 1.51.16 |
| `starlite` | PyPI | From 1.37.0 | 1.51.16 |

## How do I fix CVE-2024-32982?

Upgrade litestar to a fixed version for your release line: 2.6.4, 2.7.2 or 2.8.3.

## Is CVE-2024-32982 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-32982 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-32982 and fix it if it is affected.

What it is: CVE-2024-32982 is a high-severity path traversal vulnerability in litestar-org litestar, published on 6 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-32982 exists.

Affected packages and fixed versions:
- litestar (PyPI): affected from 2.0.0; fixed in 2.6.4, 2.7.2, 2.8.3
- litestar (PyPI): affected from 2.0.0; fixed in 2.6.4
- litestar (PyPI): affected from 2.0.0; fixed in 2.6.4
- litestar (PyPI): affected from 2.7.0; fixed in 2.7.2
- litestar (PyPI): affected from 2.7.0; fixed in 2.7.2
- litestar (PyPI): affected from 2.8.0; fixed in 2.8.3
- litestar (PyPI): affected from 2.8.0; fixed in 2.8.3
- starlite (PyPI): affected from 1.37.0; fixed in 1.51.16
- starlite (PyPI): affected from 1.37.0; fixed in 1.51.16
- starlite (PyPI): affected from 1.37.0; fixed in 1.51.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-32982/ (Markdown: https://insights.sbomify.com/CVE-2024-32982/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-32982
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-32982
- OSV: https://osv.dev/vulnerability/CVE-2024-32982

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-32982/
Summaries are generated and may contain mistakes; the official description above is the record.
