# CVE-2024-3303: Improper Neutralization of Input Used for LLM Prompting in GitLab

> Attackers can exfiltrate private issue contents via prompt injection in GitLab EE, requiring an upgrade to secure data.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Feb 2025
- **Updated:** 13 Feb 2025
- **Also known as:** BIT-gitlab-2024-3303, GHSA-8572-xjmw-7fq3, UBUNTU-CVE-2024-3303

## What is CVE-2024-3303?

CVE-2024-3303 is a medium-severity code injection vulnerability in Gitlab Gitlab, published on 13 Feb 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in GitLab EE affecting all versions starting from 16.0 prior to 17.6.5, starting from 17.7 prior to 17.7.4, and starting from 17.8 prior to 17.8.2, which allows an attacker to exfiltrate contents of a private issue using prompt injection.

Weakness: CWE-1427 (Improper Neutralization of Input Used for LLM Prompting)

## Which versions are affected by CVE-2024-3303?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 16.0.0 | 17.8.2 |

Products: Gitlab Gitlab.

## How do I fix CVE-2024-3303?

Upgrade gitlab to 17.8.2 or later.

## Is CVE-2024-3303 being exploited?

There is no known exploitation of CVE-2024-3303 in the wild and no public exploit code.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-3303 and fix it if it is affected.

What it is: CVE-2024-3303 is a medium-severity code injection vulnerability in Gitlab Gitlab, published on 13 Feb 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-3303 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 16.0.0; fixed in 17.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-3303/ (Markdown: https://insights.sbomify.com/CVE-2024-3303/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-3303
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-3303
- OSV: https://osv.dev/vulnerability/CVE-2024-3303

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-3303/
Summaries are generated and may contain mistakes; the official description above is the record.
