# CVE-2024-33664: python-jose denial of service via compressed JWE content

> Attackers can cause denial of service via resource consumption using crafted JWE tokens in the python-jose library.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Apr 2024
- **Updated:** 5 Sep 2024
- **Also known as:** CLSA-2025-1758845544, DEBIAN-CVE-2024-33664, GHSA-cjwg-qfpm-7377, PYSEC-2024-233, UBUNTU-CVE-2024-33664, openSUSE-SU-2024:0149-1

## What is CVE-2024-33664?

CVE-2024-33664 is a medium-severity denial of service vulnerability in n/a, published on 25 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

python-jose through 3.3.0 allows attackers to cause a denial of service (resource consumption) during a decode via a crafted JSON Web Encryption (JWE) token with a high compression ratio, aka a "JWT bomb." This is similar to CVE-2024-21319.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2024-33664?

3 open source packages ship an affected version, including python-jose. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `python-jose` | PyPI | All versions | 3.4.0 |
| `python-jose` | PyPI | All versions | 3.4.0 |
| `python-jose` | PyPI | All versions | 3.4.0 |
| `python-python-jose` | SUSE:Package Hub 15 SP5 | All versions | 3.0.1-bp155.3.6.1 |
| `python-python-jose` | openSUSE:Leap 15.5 | All versions | 3.0.1-bp155.3.6.1 |

Products: Python-Jose Project Python-Jose.

## How do I fix CVE-2024-33664?

Upgrade python-jose to 3.4.0 or later.

## Is CVE-2024-33664 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-33664 exists.

## Other vulnerabilities in n/a

- [CVE-2016-7036](https://insights.sbomify.com/CVE-2016-7036/): python-jose failure to use a constant time comparison for HMAC keys (critical 9.8)
- [CVE-2024-33663](https://insights.sbomify.com/CVE-2024-33663/): Security feature bypass in n/a (medium 6.5)
- [CVE-2024-29370](https://insights.sbomify.com/CVE-2024-29370/): Duplicate Advisory: python-jose denial of service via compressed JWE content (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-33664 and fix it if it is affected.

What it is: CVE-2024-33664 is a medium-severity denial of service vulnerability in n/a, published on 25 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-33664 exists.

Affected packages and fixed versions:
- python-jose (PyPI): affected all versions; fixed in 3.4.0
- python-jose (PyPI): affected all versions; fixed in 3.4.0
- python-jose (PyPI): affected all versions; fixed in 3.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-33664/ (Markdown: https://insights.sbomify.com/CVE-2024-33664/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-33664
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-33664
- OSV: https://osv.dev/vulnerability/CVE-2024-33664

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-33664/
Summaries are generated and may contain mistakes; the official description above is the record.
