# CVE-2024-33669: Passbolt Browser Extension leaks password information

> An attacker observing network traffic can infer typed passwords via excessive API calls, enabling easier brute-force attacks against Passbolt users.

- **Severity:** Medium 6.1 (`CVSS:3.1/AC:H/AV:N/A:N/C:H/I:N/PR:N/S:C/UI:R`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Apr 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-xfq4-78j7-v594

## What is CVE-2024-33669?

CVE-2024-33669 is a medium-severity vulnerability in n/a, published on 26 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in Passbolt Browser Extension before 4.6.2. It can send multiple requests to HaveIBeenPwned while a password is being typed, which results in an information leak. This allows an attacker capable of observing Passbolt's HTTPS queries to the Pwned Password API to more easily brute force passwords that are manually typed by the user.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2024-33669?

2 open source packages ship an affected version, including passbolt-browser-extension. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `passbolt-browser-extension` | npm | All versions | 4.6.2 |
| `passbolt-browser-extension` | npm | All versions | 4.6.2 |

Products: Passbolt Passbolt Browser Extension.

## How do I fix CVE-2024-33669?

Upgrade passbolt-browser-extension to 4.6.2 or later.

## Is CVE-2024-33669 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-33669 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-33669 and fix it if it is affected.

What it is: CVE-2024-33669 is a medium-severity vulnerability in n/a, published on 26 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-33669 exists.

Affected packages and fixed versions:
- passbolt-browser-extension (npm): affected all versions; fixed in 4.6.2
- passbolt-browser-extension (npm): affected all versions; fixed in 4.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-33669/ (Markdown: https://insights.sbomify.com/CVE-2024-33669/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-33669
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-33669
- OSV: https://osv.dev/vulnerability/CVE-2024-33669

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-33669/
Summaries are generated and may contain mistakes; the official description above is the record.
