# CVE-2024-33670: Passbolt API allows HTML injection

> Attackers can inject HTML into URL parameters to alter page appearance and user interaction, though JavaScript execution is blocked by CSP.

- **Severity:** Medium 4.3 (`CVSS:3.1/AC:L/AV:N/A:N/C:L/I:N/PR:N/S:U/UI:R`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Apr 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-2pg6-vw9c-qhjv

## What is CVE-2024-33670?

CVE-2024-33670 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Passbolt API before 4.6.2 allows HTML injection in a URL parameter, resulting in custom content being displayed when a user visits the crafted URL. Although the injected content is not executed as JavaScript due to Content Security Policy (CSP) restrictions, it may still impact the appearance and user interaction of the page.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-33670?

2 open source packages ship an affected version, including passbolt/passbolt_api. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `passbolt/passbolt_api` | Packagist | All versions | 4.6.2 |
| `passbolt/passbolt_api` | Packagist | All versions | 4.6.2 |

Products: Passbolt Passbolt Api.

## How do I fix CVE-2024-33670?

Upgrade passbolt/passbolt_api to 4.6.2 or later.

## Is CVE-2024-33670 being exploited?

There is no known exploitation of CVE-2024-33670 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-1000442](https://insights.sbomify.com/CVE-2017-1000442/): Passbolt API is vulnerable to XSS in the url field on the password workspace grid and sidebar (medium 5.4)
- [CVE-2025-27913](https://insights.sbomify.com/CVE-2025-27913/): Other in API (low 2.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-33670 and fix it if it is affected.

What it is: CVE-2024-33670 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Apr 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-33670 in the wild and no public exploit code.

Affected packages and fixed versions:
- passbolt/passbolt_api (Packagist): affected all versions; fixed in 4.6.2
- passbolt/passbolt_api (Packagist): affected all versions; fixed in 4.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-33670/ (Markdown: https://insights.sbomify.com/CVE-2024-33670/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-33670
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-33670
- OSV: https://osv.dev/vulnerability/CVE-2024-33670

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-33670/
Summaries are generated and may contain mistakes; the official description above is the record.
