CVE-2024-3372 MongoDB Server may have unexpected application behaviour due to invalid BSON

High 7.5 Published Updated

An attacker can cause unexpected application behavior and unavailability of serverStatus responses by sending invalid BSON metadata pre-authentication.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-3372?

CVE-2024-3372 is a high-severity denial of service vulnerability in Mongodb Mongodb, published on 14 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Improper validation of certain metadata input may result in the server not correctly serialising BSON. This can be performed pre-authentication and may cause unexpected application behavior including unavailability of serverStatus responses. This issue affects MongoDB Server v7.0 versions prior to 7.0.6, MongoDB Server v6.0 versions prior to 6.0.14 and MongoDB Server v.5.0 versions prior to 5.0.25.

Weakness: CWE-20

Which versions are affected by CVE-2024-3372?

1 open source package ship an affected version, including mongodb. It affects 1 product.

PackageAffectedFixed in
mongodb BitnamiFrom 5.0.05.0.25, 6.0.14, 7.0.6

Products include Mongodb Mongodb.

How do I fix CVE-2024-3372?

Upgrade mongodb to a fixed version for your release line: 5.0.25, 6.0.14 or 7.0.6.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-3372 being exploited?

There is no known exploitation of CVE-2024-3372 in the wild and no public exploit code.

All Mongodb Mongodb vulnerabilities

Sources

Also known as BIT-mongodb-2024-3372, GHSA-f2rm-5vrw-3cjp.

Is CVE-2024-3372 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free