# CVE-2024-3372: MongoDB Server may have unexpected application behaviour due to invalid BSON

> An attacker can cause unexpected application behavior and unavailability of serverStatus responses by sending invalid BSON metadata pre-authentication.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 May 2024
- **Updated:** 1 Aug 2024
- **Also known as:** BIT-mongodb-2024-3372, GHSA-f2rm-5vrw-3cjp

## What is CVE-2024-3372?

CVE-2024-3372 is a high-severity denial of service vulnerability in Mongodb Mongodb, published on 14 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper validation of certain metadata input may result in the server not correctly serialising BSON. This can be performed pre-authentication and may cause unexpected application behavior including unavailability of serverStatus responses. This issue affects MongoDB Server v7.0 versions prior to 7.0.6, MongoDB Server v6.0 versions prior to 6.0.14 and MongoDB Server v.5.0 versions prior to 5.0.25.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2024-3372?

1 open source package ship an affected version, including mongodb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mongodb` | Bitnami | From 5.0.0 | 5.0.25, 6.0.14, 7.0.6 |

Products: Mongodb Mongodb.

## How do I fix CVE-2024-3372?

Upgrade mongodb to a fixed version for your release line: 5.0.25, 6.0.14 or 7.0.6.

## Is CVE-2024-3372 being exploited?

There is no known exploitation of CVE-2024-3372 in the wild and no public exploit code.

## Other vulnerabilities in Mongodb Mongodb

- [CVE-2025-14847](https://insights.sbomify.com/CVE-2025-14847/): MongoDB and MongoDB Server Improper Handling of Length Parameter Inconsistency (high 8.7, exploited in the wild)
- [CVE-2026-82067](https://insights.sbomify.com/CVE-2026-82067/): Auth bypass in MongoDB Server (critical 9.2)
- [CVE-2026-13072](https://insights.sbomify.com/CVE-2026-13072/): MongoDB Improper Input Validation in Compute Mode External Data Processing Leading to Memory Corruption (critical 9.2)
- [CVE-2017-15535](https://insights.sbomify.com/CVE-2017-15535/): Denial of service in n/a (critical 9.1)
- [CVE-2026-18691](https://insights.sbomify.com/CVE-2026-18691/): Improper Authentication in MongoDB Intra-Cluster Connections Allows Credential Exposure (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-3372 and fix it if it is affected.

What it is: CVE-2024-3372 is a high-severity denial of service vulnerability in Mongodb Mongodb, published on 14 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-3372 in the wild and no public exploit code.

Affected packages and fixed versions:
- mongodb (Bitnami): affected from 5.0.0; fixed in 5.0.25, 6.0.14, 7.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-3372/ (Markdown: https://insights.sbomify.com/CVE-2024-3372/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-3372
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-3372
- OSV: https://osv.dev/vulnerability/CVE-2024-3372

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-3372/
Summaries are generated and may contain mistakes; the official description above is the record.
