CVE-2024-3374 MongoDB Server (mongod) may crash when generating ftdc

Medium 5.3 Published Updated

An unauthenticated attacker can crash the MongoDB server by triggering a fatal assertion during diagnostic metric generation.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-3374?

CVE-2024-3374 is a medium-severity denial of service vulnerability in Mongodb Mongodb, published on 14 May 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

An unauthenticated user can trigger a fatal assertion in the server while generating ftdc diagnostic metrics due to attempting to build a BSON object that exceeds certain memory sizes. This issue affects MongoDB Server v5.0 versions prior to and including 5.0.16 and MongoDB Server v6.0 versions prior to and including 6.0.5.

Weakness: CWE-617

Which versions are affected by CVE-2024-3374?

1 open source package ship an affected version, including mongodb. It affects 1 product.

PackageAffectedFixed in
mongodb BitnamiFrom 5.0.05.0.26, 6.0.15

Products include Mongodb Mongodb.

How do I fix CVE-2024-3374?

Upgrade mongodb to a fixed version for your release line: 5.0.26 or 6.0.15.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-3374 being exploited?

There is no known exploitation of CVE-2024-3374 in the wild and no public exploit code.

All Mongodb Mongodb vulnerabilities

Sources

Also known as BIT-mongodb-2024-3374, GHSA-8j48-r5wc-gvr3.

Is CVE-2024-3374 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free