CVE-2024-3379 Incorrect Authorization in lunary-ai/lunary
Unprivileged users can regenerate private keys for unauthorized projects, leading to potential privilege escalation and data exposure.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2024-3379?
CVE-2024-3379 is a critical missing authorization vulnerability in Lunary Lunary, published on 14 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
In lunary-ai/lunary versions 1.2.2 through 1.2.6, an incorrect authorization vulnerability allows unprivileged users to re-generate the private key for projects they do not have access to. Specifically, a user with a 'Member' role can issue a request to regenerate the private key of a project without having the necessary permissions or being assigned to that project. This issue was fixed in version 1.2.7.
Weakness: CWE-863
Which versions are affected by CVE-2024-3379?
It affects 1 product.
Products include Lunary Lunary.
How do I fix CVE-2024-3379?
No fix has been published for CVE-2024-3379 yet. Limit exposure of the affected software until one is available.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2024-3379 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3379 exists.
Other vulnerabilities in Lunary Lunary
- CVE-2024-8999 Improper Access Control in lunary-ai/lunary
- CVE-2024-9095 Improper Authorization in lunary-ai/lunary
- CVE-2024-7456 SQL Injection in lunary-ai/lunary
- CVE-2024-4146 Incorrect Authorization in lunary-ai/lunary
- CVE-2024-5386 Account Hijacking via Password Reset Token Leak in lunary-ai/lunary
Sources
Also known as GHSA-8pg7-v7vv-p54p.