# CVE-2024-3379: Incorrect Authorization in lunary-ai/lunary

> Unprivileged users can regenerate private keys for unauthorized projects, leading to potential privilege escalation and data exposure.

- **Severity:** Critical 9.6 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 14 Nov 2024
- **Updated:** 18 Nov 2024
- **Also known as:** GHSA-8pg7-v7vv-p54p

## What is CVE-2024-3379?

CVE-2024-3379 is a critical missing authorization vulnerability in Lunary Lunary, published on 14 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In lunary-ai/lunary versions 1.2.2 through 1.2.6, an incorrect authorization vulnerability allows unprivileged users to re-generate the private key for projects they do not have access to. Specifically, a user with a 'Member' role can issue a request to regenerate the private key of a project without having the necessary permissions or being assigned to that project. This issue was fixed in version 1.2.7.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2024-3379?

It affects 1 product.


Products: Lunary Lunary.

## How do I fix CVE-2024-3379?

No fix has been published for CVE-2024-3379 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-3379 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3379 exists.

## Other vulnerabilities in Lunary Lunary

- [CVE-2024-8999](https://insights.sbomify.com/CVE-2024-8999/): Improper Access Control in lunary-ai/lunary (critical 9.8)
- [CVE-2024-9095](https://insights.sbomify.com/CVE-2024-9095/): Improper Authorization in lunary-ai/lunary (critical 9.8)
- [CVE-2024-7456](https://insights.sbomify.com/CVE-2024-7456/): SQL Injection in lunary-ai/lunary (critical 9.8)
- [CVE-2024-4146](https://insights.sbomify.com/CVE-2024-4146/): Incorrect Authorization in lunary-ai/lunary (critical 9.8)
- [CVE-2024-5386](https://insights.sbomify.com/CVE-2024-5386/): Account Hijacking via Password Reset Token Leak in lunary-ai/lunary (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-3379 and fix it if it is affected.

What it is: CVE-2024-3379 is a critical missing authorization vulnerability in Lunary Lunary, published on 14 Nov 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-3379 exists.

Affected product: Lunary Lunary. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-3379/ (Markdown: https://insights.sbomify.com/CVE-2024-3379/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-3379
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-3379
- OSV: https://osv.dev/vulnerability/CVE-2024-3379

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-3379/
Summaries are generated and may contain mistakes; the official description above is the record.
