# CVE-2024-33851: mdanter/ecc affected by timing vulnerability in cryptographic side-channels

> A timing leak in point addition allows attackers to potentially recover private keys from the phpecc PHP library.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Apr 2024
- **Updated:** 4 Nov 2024
- **Also known as:** GHSA-3494-cfwf-56hw

## What is CVE-2024-33851?

CVE-2024-33851 is a medium-severity vulnerability in n/a, published on 27 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

phpecc, as used in paragonie/phpecc before 2.0.1, has a branch-based timing leak in Point addition. (This is related to phpecc/phpecc on GitHub, and the Matyas Danter ECC library.)

## Which versions are affected by CVE-2024-33851?

4 open source packages ship an affected version, including mdanter/ecc and paragonie/ecc.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mdanter/ecc` | Packagist | All versions to 1.0.0 | None |
| `mdanter/ecc` | Packagist | All versions to 1.0.0 | None |
| `paragonie/ecc` | Packagist | All versions | 2.0.1 |
| `paragonie/ecc` | Packagist | All versions | 2.0.1 |

## How do I fix CVE-2024-33851?

Upgrade to a fixed version.

## Is CVE-2024-33851 being exploited?

There is no known exploitation of CVE-2024-33851 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-33851 and fix it if it is affected.

What it is: CVE-2024-33851 is a medium-severity vulnerability in n/a, published on 27 Apr 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-33851 in the wild and no public exploit code.

Affected packages and fixed versions:
- mdanter/ecc (Packagist): affected all versions up to 1.0.0; no fix listed
- mdanter/ecc (Packagist): affected all versions up to 1.0.0; no fix listed
- paragonie/ecc (Packagist): affected all versions; fixed in 2.0.1
- paragonie/ecc (Packagist): affected all versions; fixed in 2.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-33851/ (Markdown: https://insights.sbomify.com/CVE-2024-33851/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-33851
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-33851
- OSV: https://osv.dev/vulnerability/CVE-2024-33851

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-33851/
Summaries are generated and may contain mistakes; the official description above is the record.
