# CVE-2024-33862: OPCFoundation.NetStandard.Opc.Ua.Core buffer-management vulnerability

> Remote attackers can exhaust memory resources via excessive messages, causing denial of service in applications using the OPC UA .NET Core library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jul 2024
- **Updated:** 2 Aug 2024
- **Also known as:** GHSA-4q2p-hwmr-qcxc

## What is CVE-2024-33862?

CVE-2024-33862 is a high-severity denial of service vulnerability in n/a, published on 5 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A buffer-management vulnerability in OPC Foundation OPCFoundation.NetStandard.Opc.Ua.Core before 1.05.374.54 could allow remote attackers to exhaust memory resources. It is triggered when the system receives an excessive number of messages from a remote source. This could potentially lead to a denial of service (DoS) condition, disrupting the normal operation of the system.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2024-33862?

2 open source packages ship an affected version, including OPCFoundation.NetStandard.Opc.Ua.Core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `OPCFoundation.NetStandard.Opc.Ua.Core` | NuGet | All versions | 1.5.374.54 |
| `OPCFoundation.NetStandard.Opc.Ua.Core` | NuGet | All versions | 1.5.374.54 |

## How do I fix CVE-2024-33862?

Upgrade OPCFoundation.NetStandard.Opc.Ua.Core to 1.5.374.54 or later.

## Is CVE-2024-33862 being exploited?

There is no known exploitation of CVE-2024-33862 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-33862 and fix it if it is affected.

What it is: CVE-2024-33862 is a high-severity denial of service vulnerability in n/a, published on 5 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-33862 in the wild and no public exploit code.

Affected packages and fixed versions:
- OPCFoundation.NetStandard.Opc.Ua.Core (NuGet): affected all versions; fixed in 1.5.374.54
- OPCFoundation.NetStandard.Opc.Ua.Core (NuGet): affected all versions; fixed in 1.5.374.54

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-33862/ (Markdown: https://insights.sbomify.com/CVE-2024-33862/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-33862
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-33862
- OSV: https://osv.dev/vulnerability/CVE-2024-33862

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-33862/
Summaries are generated and may contain mistakes; the official description above is the record.
