CVE-2024-33893 Cross-site scripting in n/a

Medium 6.1 Published Updated

Attackers can execute arbitrary scripts in the log viewer of Cosy+ devices due to improper input sanitization, requiring a firmware upgrade.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2024-33893?

CVE-2024-33893 is a medium-severity cross-site scripting vulnerability in n/a, published on 2 Aug 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Cosy+ devices running a firmware 21.x below 21.2s10 or a firmware 22.x below 22.1s3 are vulnerable to XSS when displaying the logs due to improper input sanitization. This is fixed in version 21.2s10 and 22.1s3.

Weakness: CWE-79

Which versions are affected by CVE-2024-33893?

It affects 1 product.

Products include Hms-Networks Ewon Cosy\+ Firmware.

How do I fix CVE-2024-33893?

No fix has been published for CVE-2024-33893 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-33893 being exploited?

There is no known exploitation of CVE-2024-33893 in the wild and no public exploit code.

Sources

Also known as GHSA-9q4j-4jmg-xr2j.

Is CVE-2024-33893 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free