CVE-2024-33896 Code injection in n/a

High 7.2 Published Updated

Attackers can execute arbitrary code on Cosy+ devices due to improper parameter blacklisting in the firmware.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2024-33896?

CVE-2024-33896 is a high-severity code injection vulnerability in n/a, published on 2 Aug 2024. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Cosy+ devices running a firmware 21.x below 21.2s10 or a firmware 22.x below 22.1s3 are vulnerable to code injection due to improper parameter blacklisting. This is fixed in version 21.2s10 and 22.1s3.

Weakness: CWE-78

Which versions are affected by CVE-2024-33896?

It affects 1 product.

Products include Hms-Networks Ewon Cosy\+ Firmware.

How do I fix CVE-2024-33896?

No fix has been published for CVE-2024-33896 yet. Limit exposure of the affected software until one is available.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2024-33896 being exploited?

There is no known exploitation of CVE-2024-33896 in the wild and no public exploit code.

Public exploit code: 1 Exploit-DB entry.

Sources

Also known as GHSA-fgqq-q43f-65jf.

Is CVE-2024-33896 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free