# CVE-2024-33896: Code injection in n/a

> Attackers can execute arbitrary code on Cosy+ devices due to improper parameter blacklisting in the firmware.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 2 Aug 2024
- **Updated:** 4 Nov 2025
- **Also known as:** GHSA-fgqq-q43f-65jf

## What is CVE-2024-33896?

CVE-2024-33896 is a high-severity code injection vulnerability in n/a, published on 2 Aug 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Cosy+ devices running a firmware 21.x below 21.2s10 or a firmware 22.x below 22.1s3 are vulnerable to code injection due to improper parameter blacklisting. This is fixed in version 21.2s10 and 22.1s3.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2024-33896?

It affects 1 product.


Products: Hms-Networks Ewon Cosy\+ Firmware.

## How do I fix CVE-2024-33896?

No fix has been published for CVE-2024-33896 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-33896 being exploited?

There is no known exploitation of CVE-2024-33896 in the wild and no public exploit code.

Public exploit code:

- Cosy+ firmware 21.2s7 - Command Injection (exploitdb)

## Other vulnerabilities in n/a

- [CVE-2024-33897](https://insights.sbomify.com/CVE-2024-33897/): Missing authorization in n/a (critical 9.1)
- [CVE-2024-33894](https://insights.sbomify.com/CVE-2024-33894/): Privilege escalation in n/a (high 8.8)
- [CVE-2024-33895](https://insights.sbomify.com/CVE-2024-33895/): Hardcoded credentials in n/a (medium 6.6)
- [CVE-2024-33893](https://insights.sbomify.com/CVE-2024-33893/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2024-33892](https://insights.sbomify.com/CVE-2024-33892/): Information disclosure in n/a (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-33896 and fix it if it is affected.

What it is: CVE-2024-33896 is a high-severity code injection vulnerability in n/a, published on 2 Aug 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-33896 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-33896/ (Markdown: https://insights.sbomify.com/CVE-2024-33896/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-33896
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-33896
- OSV: https://osv.dev/vulnerability/CVE-2024-33896

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-33896/
Summaries are generated and may contain mistakes; the official description above is the record.
